cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kstiegler
Frequent Visitor

Custom entity only available in Power BI via OData feed, not TDS endpoint

I created two custom entities yesterday via the Solution customization portal and they were not available in Power BI using the current Dataverse connector. However, they were available in Power BI via the OData feed. Is there a setting I'm missing that needs to be toggled for these to show up using the Dataverse connector?

kstiegler_0-1621018807485.png

 

9 REPLIES 9
ChrisPiasecki
Super User
Super User

Hi @kstiegler,

 

Did you publish customizations after creating your tables?

 

---
Please click Accept as Solution if my post answered your question. This will help others find solutions to similar questions. If you like my post and/or find it helpful, please consider giving it a Thumbs Up.

kstiegler
Frequent Visitor

@ChrisPiasecki Yep, published at the entity/table level as well as the "Publish all customizations" level, to no effect.

PowerBeeEye
Regular Visitor

Did you ever figure this out? I have the exact same issue

Hi @PowerBeeEye ,

 

Have you tried enabling Change tracking checkbox on Entity page?

 

Thanks,

Bipin

Prakash4691
Super User
Super User

Hi @kstiegler ,

As @bipinshan mentioned, enable change tracking in entity/table level will make table appears to the external systems.

 

If it answers your question. Kindly give kudo and accept as solution.

 

 

Regards,

Prakash

kstiegler
Frequent Visitor

In my case, it was a really simple solution - I just had to refresh the preview in Power Query. I haven't had the problem since then.

rampprakash
Super User
Super User

Hello @kstiegler 

 

Hope you are doing good.

 

Please make sure the field is SEARCHABLE.

 

Please mark as Answer if it is helpful and provide Kudos

 

 

Subscribe : https://www.youtube.com/channel/UCnGNN3hdlKBOr6PXotskNLA

Blog : https://microsoftcrmtechie.blogspot.com

PowerBeeEye
Regular Visitor

Thanks for all the replies. The table is already searchable. Is there another setting I need to turn on?

HI @PowerBeeEye ,

 

Can you show me what connector you are using in Power Bi?

 

I have just created new custom entity in my instance and used below Dataverse connector. I could see the newly created custom entity.

bipinshan_0-1646395919769.png

bipinshan_1-1646396202230.png

 

Make sure you are creating your custom table in correct instance. And you are checking in same instance in Power Bi.

 

Try clicking refresh button as highlighted in my above image.

 

Regards,

Bipin Kumar
Follow my Blog: https://xrmdynamicscrm.wordpress.com/

Kudos and Accept my answer if helpful!

Helpful resources

Announcements
Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Super User 2 - 2022 Congratulations

Welcome Super Users

The Super User program for 2022 - Season 2 has kicked off!

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (4,562)