cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
djsw_uk
New Member

Dynamics Customer Voice data missing from the Dataverse.

I have been having a data connector / data loss issue between Dynamics Customer Voice and the Dataverse when connecting to the Dataverse via PowerBI. 

 

Up until 2 days ago everything was working well. Survey data from Customer Voice was getting stored within Dataverse and was accessable via the connector within PowerBI. PowerBI dashboards were on scheduled refresh. The environment being used for this is/was the generic one within our tenant. 

 

2 days ago I noticed the numbers in dashboards going down. When I checked the Datverse entitiy table within PowerBI all the Project data from Customer Voice has dissapeared, despite no changes to any permissions or environment setup. When I check the Customer Voice application all the data is there. When I check the contact and activity entities within the Dataverse all the data is there - but the projects, surveys, questions all show blank tables. 

 

The only project within the Dataverse that shows using the PowerBI connector is the generic one that comes as part of Forms Pro / Customer Voice. If I create a new project then this does appear within the Dataverse entitiy table. 

 

Does anyone know of any system changes over the last 2-3 days that might have caused this, and more importantly have any suggestions on how I can get that data from the Customer Voice application back in to the Dataverse? 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @EricRegnier

 

Thanks for the reply. The issue did get resolved, but it was difficult to know how it happened. Records started to slowly appear back in the Datverse, and then after 1-2 days everything was there. The problem has not resurfaced since, so hopefully that is the end of it. 

 

Thank you for the reference link. I will review that. 

View solution in original post

2 REPLIES 2
EricRegnier
Super User II
Super User II

Hi @djsw_uk,

I know this dates to a while ago but have you resolved the issue? The typical scenario where this can happen is due to some security role changes, or record owner change that affect the accessibility of the data. 

I would also suggest opening a ticket at Microsoft at: https://admin.powerplatform.microsoft.com/support

Cheers

Hi @EricRegnier

 

Thanks for the reply. The issue did get resolved, but it was difficult to know how it happened. Records started to slowly appear back in the Datverse, and then after 1-2 days everything was there. The problem has not resurfaced since, so hopefully that is the end of it. 

 

Thank you for the reference link. I will review that. 

View solution in original post

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (3,222)