cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate III
Advocate III

Ertror writing datacardvalue to CDS entity

Hi there

A year ago I created some apps with the default canvas method. One of these apps is named "SimpleLeerkrachten". It holds names and codes for teachers at our school. U can see this in my screenshot named "App Leerkracht.JPG". De app is connected to an (upgraded) CDS entity called "Leerkracht". U can see the fields in my screenshot named "entity Leerkracht.JPG". The app worked perfectly but now we are testing it again to add new teachers to the list. Whenever I click on the + button in the app, I can see and fill in the empty fields (p.e. field "LkrCode") Now when I click on the submit button (= a check mark in my app) I get an error saying  "There is a problem with saving the data. Probably the datasource is invalid." The data is not saved in the entity. The app uses a "Submitform(EditForm1)" when I click the submit. How can I solve this issue? In the past it worked perfectly.

Thx a lot in advance for any suggestion that could lead me to a quick and defintive solution. 

Greetz, Walter

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @Walter ,

Please try to recreate connection with the data source.

The connetion may be invalid after a long time.

If the problem still exists, could you show me your formula about updating data?

The functions may have some changes in a year's time.

 

 

Best regards,

Community Support Team _ Phoebe Liu

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
Dual Super User II
Dual Super User II

Hi @Walter , 

 

Are you able to get the data from the entity? 

 

Can you please try deleting the old CDS connection and create a new one and try again?

 

 

Thanks, 

 

Community Support
Community Support

Hi @Walter ,

Please try to recreate connection with the data source.

The connetion may be invalid after a long time.

If the problem still exists, could you show me your formula about updating data?

The functions may have some changes in a year's time.

 

 

Best regards,

Community Support Team _ Phoebe Liu

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi
 
Thx a lot for all your support. In the meantime I found the solution myself. The datacards made in a previous version still used the old fieldnames. I changed the datacard field names te reflect the new cds entity field names and everything works like it did before.
 
Greetz and thx a lot.
Walter

Hi @Walter ,

If your problem has been soloved, could you mark my answer?
Thank you !

 

Best regards,

Community Support Team _ Phoebe Liu

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Users online (35,355)