cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Leidt
Frequent Visitor

Expecting a record value

Hello all,

 

I'm new on the platform and I'm trying some stuff out. So I've a submit button that when clicked submits data to a CDS. (entity: Armatuur)

 

But i can't seem to figure out how i can solve the error.. Any suggestions how to fix the error?

 

Thanks you in advance!

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
v-xida-msft
Community Support
Community Support

Hi @Leidt ,

Could you please share a bit more about the Entity the cr6c4_Armatuurtypebatterij (LookUp field) column references values from?

Could you please share more details about the formula within the Items property of the ComboBox3_2?

 

Based on the issue that you mentioned, I think there is something wrong with the formula you provided. I have made a test on my side, please take a try with the following workaround:9.JPG

On your side, please consider set the Items property of the ComboBox3_2 to folowing formula:

Choices(Armatuurs.cr6c4_Armatuurtypebatterij)    /* <-- Or Choices(Armatuurs.'Armatuur type + batterij') */

then modify your Patch formula as below:

Patch(
          Armatuurs,
          Defaults(Armatuurs),
          {
             cr6c4_Armatuurtypebatterij: ComboBox3_2.Selected
          }
)

Please consider take a try with above solution, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Leidt
Frequent Visitor

Additional information about my entity > Armatuur

v-xida-msft
Community Support
Community Support

Hi @Leidt ,

Could you please share a bit more about the Entity the cr6c4_Armatuurtypebatterij (LookUp field) column references values from?

Could you please share more details about the formula within the Items property of the ComboBox3_2?

 

Based on the issue that you mentioned, I think there is something wrong with the formula you provided. I have made a test on my side, please take a try with the following workaround:9.JPG

On your side, please consider set the Items property of the ComboBox3_2 to folowing formula:

Choices(Armatuurs.cr6c4_Armatuurtypebatterij)    /* <-- Or Choices(Armatuurs.'Armatuur type + batterij') */

then modify your Patch formula as below:

Patch(
          Armatuurs,
          Defaults(Armatuurs),
          {
             cr6c4_Armatuurtypebatterij: ComboBox3_2.Selected
          }
)

Please consider take a try with above solution, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Top Solution Authors
Top Kudoed Authors
Users online (61,146)