cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MarcGervais
New Member

Flow Performance

I have built a rather simple Flow that calls an API, parses the data and inserts it to the CDS. The API calls return extremely quickly when called via Postman, however, when executing the flow, it is currently taking over 16 hours and it is still running. Is there something I can do to improve this?

1 ACCEPTED SOLUTION

Accepted Solutions

Do you have any "Apply to Each" actions? If so, you can change the Concurrency to speed up the process. You can find more about Concurrency here: https://powerofpowerplatform.com/degree-of-parallelism-in-power-automate/

View solution in original post

3 REPLIES 3
v-xida-msft
Community Support
Community Support

Hi @MarcGervais ,

Could you please share a screenshot about your flow's configuration?

Do you mean that the HTTP Request Call takes over 16 hours without any response?

Further, could your please share a bit more about the API response? It would include large data?

 

Currently, I could not reproduce your issue on my side, and I think it is not possible within Microsoft Flow. Currently, within Microsoft Flow (Power Automate), there is an known limit with the single outgoing Request -- The maximum value of Request Timeout for synchronous calls is 120 seconds. If you have reached this limits in your flow, you would get a time out error.

 

Please check the following article for more details about the known limits with the HTTP Request:

https://docs.microsoft.com/en-us/power-automate/limits-and-config#request-limits

 

Please consider take a try to configure the "Settings" of the "HTTP" action in your flow, then turn on the "Pagination" option, set the Threshold property to 100000 (maximum value), then click "Done", try your flow again, check if the issue is solved.

4.JPG

 

5.JPG

then check if the issue is solved.

 

If the issue still exists, please consider submit an assisted support ticket through the following link:

https://flow.microsoft.com/en-us/support/pro

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Do you have any "Apply to Each" actions? If so, you can change the Concurrency to speed up the process. You can find more about Concurrency here: https://powerofpowerplatform.com/degree-of-parallelism-in-power-automate/

View solution in original post

Thanks @PowerBack19. I have adjusted the concurrency settings on my "Apply to Each" components and have executed the flow again...we shall see how much of an improvement this provides.

 

The last successful run took 1d 13:12:09. 

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (64,651)