cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SigurdFelix
New Member

Forms don't load in Model Driven Power App config

I'm doing the App-in-a -Day training from Microsoft. In the third Module I create a Business Process and then have to modify an entity form for an entity I created myself.

When I open the form the central screen which is supposed to show the form keeps showing a loading symbol as in the attachment. The same happens with any other form I try to open. I have worked incognito and not, on Chrome and Edge, at home on my computer and on my Office terminal, restarted the sessioen, deleted my internet history but nothing is working. The instructors at the Microsoft training also didn't know how to solve this.

2 REPLIES 2
Drrickryp
Super User
Super User

Hi @SigurdFelix 

I have not done the app in a day training session but a Form must have a valid datasource (a real connector, not a collection) and the item property must have a record assigned unless the form mode is New.  Then the Item property is ignored but will be assigned once the record is instantiated. To troubleshoot the issue, set the form mode to New and see if it is visible. 
If it is, then make sure the Item property matches the datasource. Usually an edit form is paired with another control that can be used to select a record from a table such as a Gallery, DataTable, Dropdown or Combobox control.  For example, if the record being chosen is in a gallery, then the item property of the edit form should look like Lookup(datasource, ID = Gallery1.Selected.ID) or if the record being chosen is coming from a dropdown control, it should be Lookup(datasource, ID = Dropdown1.Selected.ID)

Thanks for your reply. The app is based on the Common Data Service and in the second module the CDS is filled with several records. I open the form via Entities - Entity name - Forms tab - Main form (in this case device orders, but I have the same problem with standard CDS entities that I didn't create) which is automatically created when I created the Device Orders entity.

 

I'm just opening the form for the first time to add extra fields to the body. It's not in running the app.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

May UG Leader Call Carousel 768x460.png

June User Group Leader Call

Join us on June 28 for our monthly User Group leader call!

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Users online (3,035)