cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mdecap
New Member

Gallery not showing item details on mobile app or when "played" in browser

I have built a simple fitness tracking PowerApp, which uses CDS as the data source.  I built the app "from data", pointing to a custom entity.  The BrowseScreen contains a gallery, which renders properly when editing the app.  However, when users access via the mobile app or their browser using the "play" link, the gallery items do not show the information.  Additionally, the ">" icons only open the record on the DetailScreen when in editing the app.

 

One screenshot shows from the web.powerapps.com site, while the other is when played in the browser.

Editing the AppEditing the AppPlaying the AppPlaying the App

 

I've ensured all changed are saved and published.  Any ideas why the maker experience would be different than what the end user sees in the gallery?

 

The total at the bottom uses a SUM() of the Gallery Items, and is also not working.

3 REPLIES 3
v-xida-msft
Community Support
Community Support

Hi @mdecap ,

Do you mean that the CDS reocrds would not be loaded within the Gallery when you run your app within PowerApps Mobile App?

Which version is your PowerApps Mobile App in your Mobile device?

I have made a test on my side, and don't have the issue that you mentioned. The version of PowerApps Mobile App in my iOS device is 3.19022.16, the version of my iOS device is 12.1.4.

Please check if the version of your PowerApps Mobile App in your Mobile device is the latest version, if not, please upgrade it into the latest version, then run your app again, check if the issue is solved.

Also please take a try to uninstall PowerApps Mobile App from your mobile device, and re-install it again, check if the issue has been fixed.

In addition, please consider take a try to turn off the "Improved app rendering (final validation)" option within Advanced settings of App settings of your app, then re-publish your app, check if the issue is solved.

 

If the issue still exists, please consider take a try to save your CDS records into a Collection (using ClearCollect() function), then use the Collection as a data source within your Gallery instead of CDS Entity itself, re-publish your app, check if the issue still exists.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I have mobile appverion 3.19023.15

 

I've tried saving the data into a Collection, but am no longer seeing any data anymore.

 

Shouldn't setting the data source of a gallery to a CDS entity just work, without having to create a separate collection?

Seems this is related to delegation, as I have a filter on the Gallery.

 

I'm trying to filter out just records for the current user with...

 

SortByColumns(Filter(Activities,'Created By'.'Full Name' = User().'FullName'),"aaa_date",If(SortDescending1,SortOrder.Descending,SortOrder.Ascending))

 

When I comment out the Filter portion, it works as expected - however I do need to restrict records only for the current user.  Is there a different way i coudl do this, and the comparison of 'Created By'.'Full Name' = User().'FullName' appears to be the problem.

 

Thoughts?

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Users online (63,492)