cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
NuttyPistons
Resolver II
Resolver II

Importing Unmanaged Solution - Workflow Activation Failed

I am trying to import a solution into a new environment. I have exported an unmanaged solution as both unmanaged and managed. When trying to import either the managed or unmanaged solution to a new environment, it keeps failing with the xml file showing that all Workflows (flows) were processed but "Workflow Activation" is unprocessed. It does not give me a reason why.

For the managed solution, I can confirm that I was able to import this exact package to another environment before. 

Any thoughts on why this might be happening and what I can do about it?

 

NuttyPistons_1-1637274655864.png

 

NuttyPistons_0-1637274621253.png

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
NuttyPistons
Resolver II
Resolver II

Thank you to everyone for your help and suggestions.

I ended up having to create a ticket with Microsoft and in turns out it was "a known product defect that has been introduced in one of the recent upgrades and got resolved by the product team".

Everything is functioning as expected again now.

View solution in original post

6 REPLIES 6
rampprakash
Community Champion
Community Champion

Hello @NuttyPistons

 

In the attached second excel Filter STATUS to failed, you will get a detailed message over there, can you please share the same to help you.

 

Please mark as Answer if it is helpful and provide Kudos


Subscribe : https://www.youtube.com/channel/UCnGNN3hdlKBOr6PXotskNLA
Blog : https://microsoftcrmtechie.blogspot.com

Thanks for the reply. 

The only ItemType showing Status = Failure is the Solution and the only ErrorText is "A task was canceled."

 

Not very helpful I'm afraid.

NuttyPistons_0-1637333722623.png

 

Hello @NuttyPistons,

 

Try Publishing the solution and Export and Try again.

 

Please mark as Answer if it is helpful and provide Kudos


Subscribe : https://www.youtube.com/channel/UCnGNN3hdlKBOr6PXotskNLA
Blog : https://microsoftcrmtechie.blogspot.com

EricRegnier
Super User
Super User

Hi @NuttyPistons,

Are you trying to import the unmanaged solution in the same environment that you already imported the managed version? If so, that might be it. Try to import the unmanaged version in a new environment. Also, don't forget to select "Enable SDK messages and flows included in the solution" option under "Advanced Settings" in the import dialog.
Hope this helps!

NuttyPistons
Resolver II
Resolver II

Thank you to everyone for your help and suggestions.

I ended up having to create a ticket with Microsoft and in turns out it was "a known product defect that has been introduced in one of the recent upgrades and got resolved by the product team".

Everything is functioning as expected again now.

View solution in original post

EricRegnier
Super User
Super User

thanks for letting us know!

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power Apps Community Call Jan. 2022 768x460.png

Power Apps Community Call

Please join us on Wednesday, January 19th, at 8a PDT. Come and learn from our amazing speakers!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Users online (1,610)