cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Message is: Server error. Server response: Not a valid connector response…

Hi together,

 

since Saturday I receive the below Message when working with CDS connector. This message occurs from time to time and across multiple apps.

 

  • We did not change anything within the app or
  • within the connector settings

The app includes several custom entities. The error happens randomwise on them.

 

Error on Server. Server Answer: Not a valid connector response. returning message as is: { "error": { "code": 503, "source": "europe-002.azure-apim.net", "clientRequestId": "xxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx", "message": "The response is not in a JSON format.", "innerError": "The service is unavailable." } }

 

 

Any Idea is highly appreciated!

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,

 

many thanks for your answer.

 

Meanwhile everything works fine again. I did not perform any of the above steps - it just stopped throwing errors after approx. 4 days.

View solution in original post

6 REPLIES 6
Community Support
Community Support

Hi @mwoelzmueller ,

Could you please share a bit more about the error message within your app?

 

I have made a test on my side, and don't have the issue that you mentioned. The user @ankitadasgupta has faced same issue with you, please check my response within the following thread:

https://powerusers.microsoft.com/t5/General-Discussion/Message-is-Server-error-Server-response-Not-a...

 

Please check if the connection you created to the CDS connector within your app is valid. If not, please consider take a try to re-create a new connection to the CDS connector with proper credentials within your app, then check if the issue is solved.

 

Also please make sure the Network on your side is in a good condition. If the issue still exists, please consider take a try to re-create your app, then check if the issue still exists.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi,

 

many thanks for your answer.

 

Meanwhile everything works fine again. I did not perform any of the above steps - it just stopped throwing errors after approx. 4 days.

View solution in original post

Hi @mwoelzmueller ,

If you have solved your problem, please go ahead to click "Accept as Solution" to identify this thread has been solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Frequent Visitor

Same thing here in Gallery Items control:  odd thing is that the gallery still populates and no red dot error on screen - only the error message with red underline in formula (although it doesn't show on snapshot image below).

connector error.JPG

Frequent Visitor

correction on previous post:

- Data is not populating correctly.

Connector is on-premise sql server.

 

Regular Visitor

Hello,

   I had a similar issue with a table in SQL Server that contains a geography type column. As I don´t need this particular column for my app, I just have tried to create a view of the same table excluding this column and ... voila, It works!!

 

Hope to be useful, make sure that there isn´t any unusual data type

Helpful resources

Announcements
News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

Power Apps Community Call

Power Apps Community Call- January

Mark your calendars and join us for the next Power Apps Community Call on January 20th, 8a PST

PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

Users online (5,868)