cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
NHelgren
Power Apps
Power Apps

New table in Dataverse - AADUser

Hey everyone, you may have noticed a new table is available in Dataverse: "AAD User" This is a virtual table that is included in all versions of Dataverse. It connects to the AAD for the tenant the Dataverse organization is created in. You can use it to easily find people in AAD and retrieve additional details about them as well like location, job position, email and more. 

 

I have recently put out a new video that provides an overview and an example of use. You can find it on the Dataverse YouTube channel about this: https://www.youtube.com/watch?v=GHlecOwrx0A

 

20 REPLIES 20

Is that working though? The lookup still doesn't filter only to the search term. The environments are on frequent refresh

Mandarb_0-1655732670785.png

 

It was working as expected when I tried to reproduce it so there is something strange happening. Could you open a support ticket?

Mandarb
Frequent Visitor

I can do that, just not sure about the right avenue to log it through. I'm getting the same on two different customer tenants. Do I need to ask their It departments to log it? Or is there another site I can log from? 

GaryBelcourt
Regular Visitor

Hey all,

 

I opened a support ticket. We were able to verify through the Advanced Find portion of the solution that the table CAN be searched correctly so he believes there is an issue with just the lookup. Analyst who assisted is taking it away to see what he can do (reproduce and resolve).

Hi Gary. Did you have any success or feedback from your ticket? Is it worth it opening one from my side as well?

They are working on it; unsure how hard. I would most definitely open a ticket.

The Engineer who owns the code for this will be back in the office on July 5th so there is likely to be a delay in responses.

Can also confirm that in both a dev and prod environment that the lookups aren't sending through the fetchxml filter (nothing you type gets sent), so it just returns paged results. If you manually call the table with a proper filter (based on any column names) it will work, also if you add presearch filters, they also work - but whatever a user types won't get sent currently.

GaryBelcourt
Regular Visitor

WYup. Still waiting for a resolution too.

 

The engineers are reviewing this, I will get back once more information is available. 

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Users online (4,647)