cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mseto
Helper I
Helper I

Primary Field in CDS Entity not show up in Gallery!

 I have an Entity in the CDS with a field named 'OnboardingFeatureID'. This field is set to be the primary field, Text, Required. The way this field is populated, is from the 'ID' value of a SharePoint list item using Flow.

 

I created a canvas app with a gallery and added this CDS entity as the data source. I can pull the other field values into labels just fine, but when I create a label to display the 'OnboardingFeatureID', it is blank. I can go into the entity and check the particular row and verify that there is indeed a value for 'OnboardingFeatureID'. Why is this happening?

 

Thank you!

1 ACCEPTED SOLUTION

Accepted Solutions
mseto
Helper I
Helper I

Okay, well this is weird, I closed all my Power Apps browser windows completely, then came back in. Now the ID is showing up! I'm boggled!

View solution in original post

1 REPLY 1
mseto
Helper I
Helper I

Okay, well this is weird, I closed all my Power Apps browser windows completely, then came back in. Now the ID is showing up! I'm boggled!

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

Users online (3,588)