cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Cooper01
Continued Contributor
Continued Contributor

Save & Publish disabled when creating new Dataverse view?

I just created a new table and am trying to add a custom view. Save, Publish, and Save As are all disabled so I can set up the view but can't do anything with it. I am getting the same issue on a much older table so I don't think this is a timing issue.

My view has a name. Is anyone aware of what else it's checking for to either enable or disable these buttons?

1 ACCEPTED SOLUTION

Accepted Solutions
EricRegnier
Super User
Super User

Hi @Cooper01,

Did someone change your access role? Are you sure you're still system admin in that Dataverse environment? The other thing is to try in the classic solution explorer. In you solution, hit the "switch to classic" button in the menu. 

Hope this helps!

View solution in original post

10 REPLIES 10
EricRegnier
Super User
Super User

Hi @Cooper01,

Did someone change your access role? Are you sure you're still system admin in that Dataverse environment? The other thing is to try in the classic solution explorer. In you solution, hit the "switch to classic" button in the menu. 

Hope this helps!

Cooper01
Continued Contributor
Continued Contributor

Thanks for the reply @EricRegnier. I am the only one with access to this environment but I did double check and I'm still in the System Administrator security role. 

 

I checked another tenant where I am also a System Admin and am getting the same thing. So either I'm missing something really obvious with my view config which is disabling save or there's another issue.

 

Marking as solution since I'm using classic as a workaround for now.

That’s weird, the other 2 things you can try is in the preview maker portal: make.preview.powerapps.com or lodge a Microsoft Support ticket.

cheers

Anonymous
Not applicable

I am just starting out and following a training course how to use dataverse. Save is also greyed out for me

 

dice927_0-1621744734889.png

 

terho-antila
Advocate I
Advocate I

I have the same problem.

But indeed, seems to be working via make.preview.powerapps.com as @EricRegnier suggested 👌

Cooper01
Continued Contributor
Continued Contributor

@Anonymous @terho-antila another thing that's working for me is to edit an existing view (for example Active TableName) and save as.

terho-antila
Advocate I
Advocate I

I think things started working normally this morning 🙂 

asifkhawaja
Advocate IV
Advocate IV

Same here. I am still not able to update or save a view as different name. Save and Publish buttons are disabled and there is this message at the top yellow bar "View authoring is disabled for this view. You are in read-only mode." I am Power Platform Admin and System Admin in that environment. Any ideas?

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (3,141)