cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
troyhoskison
Helper II
Helper II

Some data not appearing in CDS when fed from Dataflow

Hi,

 

I have an issue where Not all the data is being created in the Entity when I do a data import from a data flow.

 

 

The Dataflow is working fine, it says, for example, it has 100 records to add. When the data flow runs it says it has been successful and performed 100 upserts. However, when I look at the entity data it isn't all there some of it is. So If I run the query again but this time filtering on one of the items that are missing, it will add the records. 

 

My gut feel is that the database is overwriting itself. i.e. record 14 is being updated later by record 45.

 

I have a primary key setup and the query produces a unique value for it. I have checked the there are no duplicates in the source data and that the destination data also doesn't have the same values. 

 

I have even set up another index on two other fields that are unique. 

 

Any thoughts?

 

Is there anyway to re-setup the primary key?

 

Troy

 

4 REPLIES 4

How are you doing your match logic? if your data has multiple records that match the key, it will update records rather than creating new ones.

I had to recreate the table again, no matter how I set up the indexes the import still failed

Hi @troyhoskison, did you get this resolve? To re-setup the alternate keys on the tables/entities, you can simply delete and recreate them.

Hi,

 

I tried that. it didn't work.

 

Troy

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Users online (2,620)