cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
365-Assist
Power Participant
Power Participant

The search in lookup for AAD Users does not work

You maybe aware that the Dataverse now supports a logical table for AAD users Announcing the AAD User Virtual Table – Find and add any AAD user to your records. | Microsoft...

 

However it seems that when searching in a Lookup column in Model Driven App does not work. If anyone know how to make it work let me know.

 

In example below I type in name (either first or last) and search does not work.

365Assist_0-1654129762532.png

 

11 REPLIES 11
bipinshan
Solution Sage
Solution Sage

Hi,

 

You would need to open Quick find view and add firstname , lastname column in Add find column.

 

https://docs.microsoft.com/en-us/dynamics365/customerengagement/on-premises/customize/choose-and-con...

365-Assist
Power Participant
Power Participant

Nice thought. However cannot do this as  the AAD Users Table is a virtual table and therefore you cannot add or modify the views.

 

365Assist_0-1654142186679.png

 

JustTinkering
Frequent Visitor

any news on this, having the same problem

Hi @JustTinkering @365-Assist 

 

Am afraid it is not Possible. Because this table directly associated with AAD Users

bronsonacoutts
New Member

I have experienced this just like you since the feature was released.  I thought I would give it a little while to see if it was resolved as sometimes things are soon after they are released.  Unfortunately, this hasn't happened.

 

I have a support ticket open with Microsoft currently and they're looking into the issue.  I'll keep you posted. 🙂

Fubar
Solution Sage
Solution Sage

As per the documentation no search is a limitation for virtual tables (4th bullet down) https://docs.microsoft.com/en-us/power-apps/developer/data-platform/virtual-entities/get-started-ve#...

bronsonacoutts
New Member

Hi all, 

 

As I mentioned I raised a ticket with Microsoft Support about this last week sometime.  I have just heard back, and the Product Team has confirmed that it is a BUG and they have provided an ETA that it will be resolved by the end of this week. 🙂

Hi, Thanks for the update, but still a bit sceptic as one of our team had also contact with an engineer and was told it is "as designed", cfr comment from Fubar. 

ntriplet
Regular Visitor

Any update on this?  Having the same issue.  Really preventing us to be able to transition to Dataverse and Model-Driven apps as it is needed in so many use cases.

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Users online (5,522)