cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
UI1222
Advocate II
Advocate II

Update Dataverse Connector from Dataverse (Legacy) Connector

Im confused.

 

When can i use the new Dataverse Connector, and when can i use the old Dataverse Connector (Legacy)? 

 

In this flow im was using the new connector, but now i can only add new steps with the old connector.  Why?

 

dataverse connector.PNG

 

Bottomline, i would like to upgrade all my flows to use the new Dataverse connector, but in many cases i cant choose it, when i search for it.

1 ACCEPTED SOLUTION

Accepted Solutions
UI1222
Advocate II
Advocate II

@mlengenfelder1  i have learned since i made this post that if you move or create the flow in a solution, you can pick and/or upgrade which Dataverse connector you are using.  

Flows outside solutions doesn't have this feature. I hope this changes soon, cause its quite confusing. 

View solution in original post

13 REPLIES 13
ChrisPiasecki
Super User
Super User

Hi @UI1222,

 

You can use the new connector when authoring the Flow within an environment. The only time where you cant use the new connector is when using Azure Logic Apps, or you want to retrieve data from a different environment than the one you are authoring the flow in.

 

There used to be an issue where you couldn't choose the new connector when the flow was authored outside of a solution, but that was resolved some time back. You should be able to pick the new connector as its already available in your current flow.

 

If you're not authoring the flow in a solution currently, you may want to give that a try to see if it helps.

 

---
Please click Accept as Solution if my post answered your question. This will help others find solutions to similar questions. If you like my post and/or find it helpful, please consider giving it a Thumbs Up.

 

 

UI1222
Advocate II
Advocate II

Hi @ChrisPiasecki 

 

I have 30+ flows within the same environment. I cant find any pattern to where i can use the old connector vs. the new connector. 

Im not connecting to data from other environments.

 

The flows are not in a solution, but i dont see how that should chance anything.

 

Its right there 🙂 but only sometimes...

 

dataverse connector 2.PNG

 

Maybe the issue you are referring to, isn't solved anyway. do you know where i can find more info on that?

bettc
Helper I
Helper I

I am having this issue as well, its only there intermittently

 

ChrisPiasecki
Super User
Super User

Hi @UI1222,

 

I don't have a specific link that mentions the fix to that issue, just that Ive seen many articles previously from months back that described the issue and I used to also experience it, but have not had that issue for months now. 

 

I'd recommend maybe try re-adding the step(s), or rather than continue spinning your wheels, recreate the flow inside a solution if possible, which is recommended in general. I'd also recommend opening a ticket with Microsoft support to report the issue as it is unexpected behavior.

 

---
Please click Accept as Solution if my post answered your question. This will help others find solutions to similar questions. If you like my post and/or find it helpful, please consider giving it a Thumbs Up.

NielsL
Helper V
Helper V

Did any of you find a solution for this issue? I am experiencing the same thing. 

Unfortunately not, 

 

I had a session with Microsoft support last week, regarding another problem, and i asked them how to upgrade the legacy connector, but they didn't know how to do it.  

Thanks for getting back, @UI1222

 

I think it will be quicker for me to simply recreate the flows that uses the legacy connector than spending time troubleshooting with Microsoft Support.

UI1222
Advocate II
Advocate II

I still have this problem... 
I have found a pattern. when i start a new flow from scratch, all the Dataverse connections are available. As long as i stay in the first session, everything is fine. if i leave the first session and come back another day, the new Dataverse connections are no longer available. 

 

Can anyone recognize this? 

mlengenfelder1
Frequent Visitor

I ran into this issue today. Starting a new flow it works, but once I copy some steps from a different flow over, then save/close/reopen I can no longer use the new Dataverse connection, only legacy option is available.

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Users online (2,511)