cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Dorinda
Post Prodigy
Post Prodigy

User doesn't have 'read' privilege to this entity with logical name: 'new_expenses'.

I am trying to use the Expense report that was created by @RezaDorrani, however in the flow it is giving me this error

 

User doesn't have 'read' privilege to this entity with logical name: 'new_expenses'.

 

I am not sure how to fix this error,  I have gone in and ensured that user and user setting are set to at least read.

 

Any dir

1 ACCEPTED SOLUTION

Accepted Solutions
rampprakash
Community Champion
Community Champion

Hello @Dorinda,

 

Can you please try below steps to confirm the same

 

Navigate to https://make.powerapps.com

Click Gear Icon at the top

Click Advance Settings

Click Settings then Security

Open the Security Role Associated to the Users

Click Custom Entities

search for EXPENSE table and make sure Read privilege's available or not.

 

Please mark as Answer if it is helpful and provide Kudos


Subscribe : https://www.youtube.com/channel/UCnGNN3hdlKBOr6PXotskNLA
Blog : https://microsoftcrmtechie.blogspot.com

View solution in original post

3 REPLIES 3
dpoggemann
Super User
Super User

Hi @Dorinda ,

 

In the flow you will have the ability in your Dataverse steps to "use invoker's connection" and if so then it will run as the user that caused the flow to be invoked and if the user does not have the security to read the table then you will get this type of error.  Please check your connection that the step is running under in the flow.  

 

Also in the Trigger under "Advanced Options" you will have the ability to select the "Run As" so set this as expected for your process to the right user.

Screen Shot 2021-12-06 at 7.55.49 PM.png

 

Hope this helps. Please accept if answers your question or Like if helps in any way.
Thanks,
Drew
rampprakash
Community Champion
Community Champion

Hello @Dorinda,

 

Can you please try below steps to confirm the same

 

Navigate to https://make.powerapps.com

Click Gear Icon at the top

Click Advance Settings

Click Settings then Security

Open the Security Role Associated to the Users

Click Custom Entities

search for EXPENSE table and make sure Read privilege's available or not.

 

Please mark as Answer if it is helpful and provide Kudos


Subscribe : https://www.youtube.com/channel/UCnGNN3hdlKBOr6PXotskNLA
Blog : https://microsoftcrmtechie.blogspot.com

rampprakash
Community Champion
Community Champion

Hello @Dorinda,

 

Can you please try below steps to confirm the same

 

Navigate to https://make.powerapps.com

Click Gear Icon at the top

Click Advance Settings

Click Settings then Security

Open the Security Role Associated to the Users

Click Custom Entities

search for EXPENSE table and make sure Read privilege's available or not.

 

Please mark as Answer if it is helpful and provide Kudos


Subscribe : https://www.youtube.com/channel/UCnGNN3hdlKBOr6PXotskNLA
Blog : https://microsoftcrmtechie.blogspot.com

View solution in original post

Helpful resources

Announcements
User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Users online (2,049)