cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bs-dev001
Advocate I
Advocate I

View in Model Driven app not showing all records from Virtual Table

We've started using Virtual Table. The table has existed in Azure SQL and we needed to see it in our Model Driven app. So we followed the following step precisely https://docs.microsoft.com/en-us/powerapps/maker/data-platform/create-edit-virtual-entities, got ready to see records from a virtual table, and what we saw is such a disappointment!

 

Please take a look at this image.    virtual_entity_record_showing_only_one.png

 

There is no modification to view's filter criteria. The number of records in the bottom is absolutely correct. (We did select count on the table in Azure SQL).  We expect to see 25 records in this screen but the view shows only one record from Virtual Table.  

 

This is very puzzling. 

 

Can someone guide us how to troubleshoot?

 

 

11 REPLIES 11
bipinshan
Solution Sage
Solution Sage

Hi @bs-dev001 ,

 

Have you tried to check the records from advanced find/web api/c# console application apart from views?

 

Thanks,

Bipin

I don't know what advanced find/web API and so on that you are referring to.  But from the Data tab, more records are visible.   This could be a view issue but I am sure nothing is applied to the view filter.

virtual_entity_record_showing_only_one_1.png

 

bipinshan
Solution Sage
Solution Sage

Hi @bs-dev001 ,

 

Have you tried creating new view to see if data appears?

 

Steps to create new view from maker portal - 

Login to make.powerapps.com then Select Data ->Tables->Select your table->Views

 

Click on Add View button from top ribbon-> Give name and description -> Select Create ->

Add columns based on your need ->Save and Publish your changes

 

Would you be able to share scrrenshot of your View from Modern Designer?

 


Regards,

Bipin Kumar
Follow my Blog: https://xrmdynamicscrm.wordpress.com/

Kudos and Accept my answer if helpful!

created a view from maker portal.  still shows only one record.  this is the weirdest thing I've experienced in Power Platform. @bipinshan 

virtual_entity_record_showing_only_one_2.pngvirtual_entity_record_showing_only_one_3.png

apellizzari
Frequent Visitor

hi i've the same problem... just this afternoon making the app.

Still using virtual entities from sql (on premise gateway connector).

If i edit  the view in "classic mode" i can see all the records (see attachment)

@bipinshan is this a bug in view?

apellizzari
Frequent Visitor

@bipinshan

I have read in some supporting documentation that the cause could be the fact that the virtual table does not have the primary key in the data source

bs-dev001
Advocate I
Advocate I

@apellizzari @bipinshan 

We've deleted everything and created a virtual table again using Virtual Connector Provider although it states "Preview"

 

https://docs.microsoft.com/en-us/powerapps/developer/data-platform/virtual-entities/create-virtual-t...

 

It did not allow us to specify primary key at Step11.  The behavior was that as soon as "Create or Refresh Entity" was switched to Yes "Primary field of the Virtual Entity" was populated with option values.  There is no primary key field in Option.  This is very very puzzling.

 

We ended up following the path of what this original article says

https://docs.microsoft.com/en-us/powerapps/developer/data-platform/virtual-entities/create-virtual-t...

 

and noticed in the very last part it says

https://docs.microsoft.com/en-us/powerapps/developer/data-platform/virtual-entities/create-virtual-t...

  1. You are seeing only one (1) record in your virtual table even though you have more in your source table.

    Solution: Check your source table and make sure it has primary key defined.

i think this is the documentation @apellizzari read.

Simply put, this needs more elaboration.  The primary key in the source table needs to be GUID.

 

so for us, adding a new primary key column with GUID type solved the problem.

apellizzari
Frequent Visitor

hi @bs-dev001 , @bipinshan 

I entered the GUID in the sql table and it seems to be firing.

The thing I can't understand is why, at this stage it only proposes fields of "text" and not the keys that have been defined in the table ..
I have no idea how to behave

from the document:

"...Set the Primary field of the virtual entity by select the appropriate column name listed. The drop-down lists all the columns of datatype string (nvarchar) that are eligible to be used as the primary field for the virtual table."

In my case the field listed below isn't a primary field 

 

external_key.jpg

Helpful resources

Announcements
Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on August 17, 2022 at 8am PDT.

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Users online (4,157)