cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
daveone
Level: Powered On

LoadData doesn't work in version 2.0.720 for a big collection

I have an app with a collection saved offline; it has more than 1200 rows loaded via web service.

My app is working correctly in a mobile Asus Zenfone with Android 6.0.1 and PowerApps version 2.0.706, it also working correctly in iPad with iOS 10.3.3 and PowerApps version 2.0.676; 

 

I found the problem with Samsung J7 which has Android 7.0 and PowerApps version 2.0.720

The result of the LoadData for this collection is 0 rows.

 

4 REPLIES 4
Community Support Team
Community Support Team

Re: LoadData doesn't work in version 2.0.720 for a big collection

Hi @daveone,

 

What is your data source on this issue? If you recreate the app using 2.0.720, will the same issue occur?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
daveone
Level: Powered On

Re: LoadData doesn't work in version 2.0.720 for a big collection

Hi Mona,

the data source is a json containing more than 1200 rows received via custom connection created with OpenAPI.

The app is created with web PowerApps environment and then published and shared to the users.

 

No any row is written in the collection with LoadData when I use the app with Samsung J7 which has the PowerApp version 2.0.720 installed while with the other two equipments (Asus Zenfone and iPad) which have both a previows version, my app works fine (all row are written in the collection with LoadData)

 

Regards,

 Davide

daveone
Level: Powered On

Re: LoadData doesn't work in version 2.0.720 for a big collection

Hi Mona,
is there any news for the solution of this issue?

I made some other tests and the problem is surely releted to the version 2.0.720 of PowerApps.

 

Loading a collection saved locally, the command LoadData works fine with PowerApp version 2.0.706 (OS Android 6.0)
With the same OS, after having updated PowerApps to version 2.0.720, the collection saved locally (now 1340 rows) is not loaded by the LoadData command.

 

This is a critical issue for my project and I ask you if there is chance to solve it urgently.

 

Best regards,
 Davide

daveone
Level: Powered On

Re: LoadData doesn't work in version 2.0.720 for a big collection

Hi Mona,
I found a bug in my code; the anomaly was due to a collection not initialized correctly when the app started.

We can consider closed this support request

 

Regards,
 Davide

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Users Online
Currently online: 47 members 4,930 guests
Please welcome our newest community members: