cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
OOlashyn
Level: Powered On

[BUG] context.webAPI.retrieveMultipleRecords is not a function

Hi All,

I have encountered this error today. My control stopped working because it says that "context.webAPI.retrieveMultipleRecords is not a function".  To verify that issue is not because of the errors in my code I called context.webAPI.retrieveMultipleRecords in the init method and I use the code from this example. Previously everything worked fine. Does anyone else experience this issue as well?

1 ACCEPTED SOLUTION

Accepted Solutions
OOlashyn
Level: Powered On

Re: [BUG] context.webAPI.retrieveMultipleRecords is not a function

Hi All,

I found a way to make it work again: in ControlManifest.Input.xml file added 

    <feature-usage>
      <uses-feature name="WebAPI" required="true" />
    </feature-usage>

and everything works. However, without this line of code, it still doesn't work.

View solution in original post

4 REPLIES 4

Re: [BUG] context.webAPI.retrieveMultipleRecords is not a function

It is an internal bug which has been reported I am also facing same issue.

https://powerusers.microsoft.com/t5/PowerApps-component-framework/PCF-Control-Question/td-p/319656/p...

DannyJia
Level: Power Up

Re: [BUG] context.webAPI.retrieveMultipleRecords is not a function

I have the same issue. My control suddenly stopped working, although I haven't changed anything. I have debugged it and found all the methods in WebAPI object are showing null values. Obviously it is a Microsoft bug. It is a very serious bug and there is nothing we can do until Microsoft fixes it.
OOlashyn
Level: Powered On

Re: [BUG] context.webAPI.retrieveMultipleRecords is not a function

Hi All,

I found a way to make it work again: in ControlManifest.Input.xml file added 

    <feature-usage>
      <uses-feature name="WebAPI" required="true" />
    </feature-usage>

and everything works. However, without this line of code, it still doesn't work.

View solution in original post

GLMSDev
Level: Powered On

Re: [BUG] context.webAPI.retrieveMultipleRecords is not a function

Thanks. You saved me lot of time 🙂

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,411)