cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
LarsMartin
Level: Powered On

Deployment of environment variables

Hello,

I'm trying the usage of the new environment variables and experience a behavior I'm not sure what to think about it.

  1. I created an environment variable with a default value and a current value in DEV. 
  2. I added the variable to a solution and deployed it to the target environment.
  3. I adjusted the current value in the target environment as it is system-specific.

Question:

Why is the current value overwritten by the next deployment of this solution?
 
I would expect the environment variable is updated but the current value remains the same.
1 ACCEPTED SOLUTION

Accepted Solutions
LarsMartin
Level: Powered On

Re: Deployment of environment variables

Failure was in front of the display.

I created the current value within the solution and did not remove it before exporting the solution.

 

2019-11-04 19_16_31-.png

View solution in original post

3 REPLIES 3
LarsMartin
Level: Powered On

Re: Deployment of environment variables

Failure was in front of the display.

I created the current value within the solution and did not remove it before exporting the solution.

 

2019-11-04 19_16_31-.png

View solution in original post

Community Support Team
Community Support Team

Re: Deployment of environment variables

Hi @LarsMartin ,

Could you please share a bit more about your issue?

Do you mean that the current value is overwritten automatically when deploying your solution to another Environment?

Further, do you want the current value to remain the same across different environments?

 

Based on the issue that you mentioned, I think you have some misunderstanding with the Default value or Current Value of Environment Variable.

Currently, within PowerApps, only the Default value of Environment variable could remain the same across different environments. The Current value is scope to your current PowerApps environment, when you deploy the Solution including Environment variable to another different Environment, the Current value would be lost.

Please check the following blog for more details:

https://powerapps.microsoft.com/en-us/blog/environment-variables-available-in-preview/

 

If you want the Environment Variable value to remain the same across different environments, please consider set a Default value for it rather than Current value.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
LarsMartin
Level: Powered On

Re: Deployment of environment variables

Hello,

as already stated above it was my fault.
I created the current value within the solution and did not remove it before exporting the solution. As result the current value was overwritten in the target environment.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 155 members 5,403 guests
Recent signins:
Please welcome our newest community members: