cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TxH
Advocate IV
Advocate IV

App with Named Formulas crashes in 3.22091.11 and 3.22092.12

I'm able to create Named Formulas in Power Apps Studio, but when I publish the app and try to run it, it crashes with the message "This app stopped working. Try refreshing your browser".

Running the app in the Studio works without problems.

 

There is only one Named Formula defined in this app:

App.Formulas = VERSION = "1.0.100";

Screen1.Label1.Text = VERSION

 

That's it, that's the app.

 

I tested as follows:

  • Preview Environment (WUS)
  • Developer Environment (Europe)
  • Windows 10 and 11
  • Browser
    • Edge
    • Edge InPrivate Mode
  • Power Apps app on Android
  • Power Apps versions
    •   3.22091.11 (recommended)
    •   3.22092.12

 

29 REPLIES 29
ShantanuP
Power Apps
Power Apps

@zmorek I tried following in version 3.22091.23 and it worked.

 

Formula =

f_Admin = Lower(User().Email) in [
"email1@email.com",
"email2@email.com"
];

 

Add a label

Label.Text = f_Admin

 

Save publish it. The app loaded fine. Can you please share session Id for app playing session? 

Also if you could send me your msapp (direct message me) which has the issue then that would help with reproing the issue as well.

zmorek
Super User
Super User

Will do - was in the process of rolling back my version after attempting again. Messaging you shortly.

certifiedglassy
Advocate I
Advocate I

Same is happening here. PowerApps keeps defaulting me to 3.22091.11, but even saving it under later versions gives me the hanging issue.

JamesSnaps
Advocate V
Advocate V

I wish I'd read this earlier. I tried updating two of my apps to the latest version and experimenting with a named formula. All seemed good so I published. Now both apps are basically non-functional. Rolling back to a previous version works sometimes. Tried version 3.22092.19 to see if that made a difference but nope, both apps dead on launch.

JAA_
New Member

For me, even disabling Named Formulas didn't get the app working again.

 

I needed to roll back to authoring version 3.22085.14 to get the app working.

 

3.22091.11 seems to be a dodgy version - it doesn't feature in the list of available versions, but if I enabled Named Formulas, it reverted to that version and failed to start.

ShantanuP
Power Apps
Power Apps

The fix for named formula issue is not deployed in all regions. But it will be by the end of next week. 

Hi @ShantanuP,

Do I understand correctly that the versions 22091.23 and 22092.19 can be selected under Settings, but may not yet be installed in the tenant?

TxH
Advocate IV
Advocate IV

It was premature of me and a mistake to mark this issue as currently resolved.
It is currently not stable to use versions 22091.23 or 22092.19, as reopening the app in Studio often resets the version to the not quite flowless 22091.11, even though this version obviously no longer exists.

image.png
I currently advise against enabling Named Features in an existing app, as there are reports that it is sometimes not possible to disable the functionality again without problems.
If you absolutely want to test the functionality at this point, you should create a completely new app, which can be deleted again very easily.

- Of course, all this is just my opinion as a user -

 

ShantanuP
Power Apps
Power Apps

We have identified the issue where disabling the feature also breaks the app and working on fixing this. Following work around should work in these cases until then.

- Enabled NamedFormula feature

- Add following named formula (You can add additional ones and use them in the app if you want.)

unusedVar = Office365Outlook.GetEmailsV2({from:"nobody@contoso.com"});

- Save and publish the app.

 

 

Not sure this fixes anything for me unfortunately. I've followed your steps and the app still won't open, just sits on the spinning loading icon but never actually loads. Version still showing as 3.22091.11. I did notice a new 3.22094.7 available so tried that, but no difference, except it now stripped the background colour from the app icon and also crashed whenever I try and refresh the component library, so things are going great! 

 

Edit: I tried creating a blank new app and the code did prevent it from crashing. So it's just my existing apps that it hasn't helped.

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Users online (5,011)