cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Billy_C
Helper V
Helper V

Custom role has no access to environment

Hi there,

 

So I have been trying to setup a custom role for a new user, I have followed the documentation and imported a solution with the minimum requirements to add a user to a model driven application.

Setting the user as an administrator then there are no issues, but with custom role access to the application or environment is denied.

 

I have also added the user to the application using the share button, and also to the environment so everything over there should be fine I think.

 

So the issue is only with the custom role which I have setup using the minimal requirements to run an app which didn't work so I then started to look at the base user and set the roles equally but still no success so I don't know why the user is not getting any access to both the environment or the app.

 

Any ideas on this?

 

Thanks in Advance,

 

Billy Cottrell

1 ACCEPTED SOLUTION

Accepted Solutions
Billy_C
Helper V
Helper V

Hi @ChrisPiasecki,

 

Yes I have added the role to both the application and the user, now it appears to be working seems like I just had to wait before the license kicked in.

I'll see if I can minimize the overall access a bit more since I used system administrator as the base user.

 

Thanks for the help!

View solution in original post

2 REPLIES 2
ChrisPiasecki
Super User
Super User

Hi @Billy_C,

 

Can you confirm that you also associated your custom role with your model driven app? If the security role assigned to your user only has read privileges to the model driven app table, then you must ensure that the same security role is associated with the app. 

 

https://docs.microsoft.com/en-us/powerapps/maker/model-driven-apps/share-model-driven-app#preview-sh...

 

---
Please click Accept as Solution if my post answered your question. This will help others find solutions to similar questions. If you like my post and/or find it helpful, please consider giving it a Thumbs Up.

Billy_C
Helper V
Helper V

Hi @ChrisPiasecki,

 

Yes I have added the role to both the application and the user, now it appears to be working seems like I just had to wait before the license kicked in.

I'll see if I can minimize the overall access a bit more since I used system administrator as the base user.

 

Thanks for the help!

View solution in original post

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (1,587)