cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SebastianL
New Member

Embed Problem with iframe

Hi guys,

 

i just have a problem to embed a power apps app with an iframe on my website.

It is a strange problem. When the file with the iframe is uploaded to my server and i open it with my domainname there is only a running circle but when i open the same file from my local client, it loads the app and i can use it.

 

I just deleted all cookies, tried different browsers like Egde Chromium, Google Chorme, Firefox... On all theese browsers, there is only the circle but when i open it with the Internet Explorer 11, the app loads perfectly.

 

Whats going on here? 

 

My source code contains only the following:

 

<html>
<head>
    <title>Members</title>
<body>
    <iframe width="100%" height="100%" src="https://apps.powerapps.com/play/MYAPPID?source=website&screenColor=rgba(165,34,55,1)" allow="geolocation; microphone; camera">
</body>
</head>
</html>

 

 

When i add the iframe code to my joomala site, i have the same problem with just the circle.

 

With the dev tools i get this failures when i open it:

 

 

Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://apps.powerapps.com/play/C:/Agent/_work/30/s/obj/Assets/js/Player.Views/App/App.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://apps.powerapps.com/play/Player.AppLoader.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/webplayer/hashedresources/u51pa8ra6tm30/js/C:/Agent/_work/30/s/obj/Assets/js/PowerAppsAuthFlowSdk/PowerAppsAuthFlowSdk.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/webplayer/hashedresources/djfq074j10lk7/js/player.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/webplayer/hashedresources/o9lkujqn830s9/openSource/oss-phase1.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/app/s5i89talcktdc/js/winjs/base.min.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/app/b8tu7muhotot1/publish/js/C:/Agent/_work/30/s/obj/Assets/js/Core/Core.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/app/upd6ru38m8njc/publish/js/C:/Agent/_work/30/s/obj/Assets/js/AppMagic.TestStudio/AppMagic.TestStudio.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/app/b38nujathsh91/publish/js/C:/Agent/_work/30/s/obj/Assets/js/Core.ClientInfra/Core.ClientInfra.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/app/bkttn2g42vpg5/publish/js/C:/Agent/_work/30/s/obj/Assets/js/Core.UI/Core.UI.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/app/gvtbpckb6a45a/js/C:/Agent/_work/30/s/obj/Assets/js/Player.Common/Player.Common.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://pa-content.azureedge.net/resource/webplayerdynamic/publishedapp/WebPlayer.LoaderWithCordova.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/app/o1mk3k3omhd97/js/C:/Agent/_work/30/s/obj/Assets/js/Core.Services/Core.Services.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/app/8oksghpfr77j0/js/AppMagic.PublishedApp.Player.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/app/65dekugibpne1/publish/js/aphrodite.publishedapps.min.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/app/rja1rbunt28f9/ctrllib/gallery/js/Gallery.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Fehler beim Laden der Quell Zuordnung durch devtools: Der Inhalt für https://content.powerapps.com/resource/app/2pugn6jm5v9o0/publish/js/HostControl.js.map konnte nicht geladen werden: HTTP Fehler: Statuscode 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

 

Can anyone help to solve this issue?

By the way: When i open the file from my local client, i see some of the above failues but not all.

 

Best regards

Sebastian

1 ACCEPTED SOLUTION

Accepted Solutions
SebastianL
New Member

we can close this thread. It was my fault. Just opend the site via http instead of https.

Just configured a redirect now. 😉

View solution in original post

2 REPLIES 2
SebastianL
New Member

we can close this thread. It was my fault. Just opend the site via http instead of https.

Just configured a redirect now. 😉

Hi SebastianL,

 

Thanks for sharing the solution 🙂

 

Regards,

JAvier

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Users online (1,166)