cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Rentatank
New Member

Error with no change to app or CDS

Hi,

 

I have an app that I have been building for a few months. I completed it 1.5 weeks ago and it was working until today.

 

I have an onstart = ClearCollect(ClientCollect,Contacts) and today im now getting the below.

 

"The requested operation is invalid. Server Response: Could not find a property named '*_label' on type 'Microsoft.Dynamics.CRM.*."

 

But nothing has changed.

 

Regards,

Conor

 

6 REPLIES 6
v-xida-msft
Community Support
Community Support

Hi @Rentatank,

Does this issue occur within your ClearCollect function?

I have made a test on my side, and don't have the issue that you mentioned. The screenshot as below:6.JPG

I think this issue may be related to the connection to your D365 Entity (Contacts) from your app. Please take a try to remove the connection from your app, and then re-add a new connection to your Contacts entity, then re-publish your app to check if the issue is solved.

In addition, please also consider take a try to type your ClearCollect formula wihtin the OnVisible property of the first screen of your app instead of the OnStart property of the first screen, then re-load your app, check if the issue still exists.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Kris,

 

Ill test this now. I should of also mentioned that it works in preview. Just not on the published app.

 

Regards,

Rentatank

Tested as you said and am still facing the same error.

 

The requested operation is invalid. Server Response: Could not find a property named '_*_label' on type 'Microsoft.Dynamics.CRM.contact'.
 
 

I'm getting a similar issue with a CDS-based canvas app.  It works fine in preview mode for me too, but I get the error in the Web player, and mobile player on both iOS and Android.

 

My app references two custom CDS entities, and I get a similar error for each, as follows:

 

  • The requested operation is invalid. Server Response: Could not find a property named '_statecode_label' on type 'Microsoft.Dynamics.CRM.cr933_sftfperson'.
  • The requested operation is invalid. Server Response: Could not find a property named '_cr933_supplierproductverification_label' on type 'Microsoft.Dynamics.CRM.cr933_sftforganisation'.

 

I don't know what the "_statecode_label" refers to on the first of these.  However, the "_cr933_supplierproductverification_label" looks as if it's referring to a "Multi Select Option Set" field (in case that helps!)

 

I have tried removing the data sources and re-adding them as suggested above, but with no change in the situation.

 

Is there anything else you can suggest, please?

Solved. I turned off "Explicit column selection" in Advanced Settings, and things are working again. See https://powerusers.microsoft.com/t5/General-Discussion/App-works-in-editor-preview-but-not-published....

Thanks @Interlock ! This 3 year old thread solved it for me too! 

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Users online (3,741)