cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lachiee1
Regular Visitor

Importing solution fails as it requires the "Active" solution - Urgent

Hi guys,

I am trying to import my solution from dev environment to production. Previously, I didn't have any problem with this action, but now I get the following error:

lachiee1_0-1599814338977.jpeg

I assume, this "Active" solution must be some internal solution, as I couldn't find it in any of my environments. 

Additional info: this solution requires integration with Business Central, however, I solved these dependency issues (it requires then the solutions "MicrosoftDynamicsNavIntegration" and "bcbi_CdsBaseIntegration", which are already there).
Furthermore, the solution includes the Dynamics Customer Service Hub as well.

Edit: by testing it with a dummy solution, I face the same error if the Dynamics Customer Service Hub is included in the solution, but without that app, it works.

Thank you for any input! It is kind of urgent now!:)
Have a great day,
Laci

6 REPLIES 6
ben-thompson
Solution Sage
Solution Sage

Scrub that previous post. There is an issue in the Import routine of Make.powerapps.com which shows that you have an error with the Active Solution without telling you what the actual issue is - which is likely to be a missing dependency in your solution.

 

To identify the issue - you need to start off at the old All solutions page in the advanced settings so orgxxx.crmyy.dynamics.com/main.aspx?settingsonly=true and kick off the import from there. That will bring up the actual issue in a way that can be fixed.

---
If this post has answered your question please consider it for "Accept as Solution" or if it has been helpful give it a "Thumbs Up".

Thanks for the tip!

Unfortunately, I got there the same message, but in different formulation, i.e. "The following components are missing in your system and are not included in the solution. Import the managed solutions that contain these components (Active) and then try importing this solution again."


I found another thread with this message, but there was no real solution found. 

As I said before the way to identify the issue is to use the old solution import routine within Dynamics 365 advanced settings - I did that yesterday to resolve the issue we had importing a solution.

---
If this post has answered your question please consider it for "Accept as Solution" or if it has been helpful give it a "Thumbs Up".

Given that I'm seeing other people with the same problem I've added a blogpost about it at https://www.processpower.dev/how-to-install-a-powerapp-solution-when-the-active-solution-is-missing/

---
If this post has answered your question please consider it for "Accept as Solution" or if it has been helpful give it a "Thumbs Up".
Anonymous
Not applicable

I had this issue with a solution that contained only Power Automate flows. To solve this I exported the solution from the Classic interface. This then told me that there were missing dependencies in the solution and what they were, it also told me that I could add the dependencies in the solution by editing the solution (in Classic mode) and using the "Add required components" button 

tchagan_0-1602402820925.png

I did this for each Flow in the solution, saved the solution then exported it, there were no issues on the export. I then imported into another environment successfully.

 

regards

Terry

 

---

please mark as solution if this has met your requirements

MuhannedNidal
Frequent Visitor

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Users online (17,558)