cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
panterra
Level 8

Not able to connect to the On-Premises Data Gateway with Custom Connector

Hi everyone,

 

I am able to connect with the On-Premises Data gateay through Flow. However, I am not able to use the Gateay for a Custom Connector in PowerApps. 

 

Here is the issue: 

  • I have created a On-Premises Custom Conenctor in PowerApps.
  • When I am prompted to select a Gateway by the Connector, none are available 'No gateways found'
  • Screenshots Below

Here is the strange part: 

  • I am able to use the Gateway from MS Flow! using the HTTP with Azure AD Action
  • Screenshots Below

Has anyone had a similar issue. Was there an extra step that needed to be taken to be able to access the Gateway from within PowerApps?

 

Any suggestions would be welcomed!

 

Many thanks,

Sean

 

No GAteways in PowerApps.PNGGateway is not available for selection in PowerAppsHas Gateway.pngGateway is available for selection in MS Flow

 

 

3 REPLIES 3
Community Support Team
Community Support Team

Re: Not able to connect to the On-Premises Data Gateway

Hi @panterra ,

 

Do you firstly install one gateway?

If you have installed one gateway, before you connect the data source , you need to sign in Gateway.

20190502GateWay1.PNG

And Gateways are only support the default environment, could you please check whether you are in the right environment in PowerApps?

More information:

gateway-management

working-with-environments

 

Sometimes you can try to uninstalling theGateway (old version) and installing the On-premise data gateway version to fix the problem.

 

Hope these could be helpful.

 

Best Regards.

Yumia

panterra
Level 8

Re: Not able to connect to the On-Premises Data Gateway

Hi  @v-yuxima-msft! Thank you for your response. Here are some more details. 

 

The gateway is already installed and confiugred - it is setup in the default environment too. 

 

I have collected more details.

 

  • What's interesting is that from within PowerApps the HTTP with Azure AD Connector allows me to select a gateway.  See image below. 
  • I am unable to select a gateway when I try to do this from a Custom Connector (see screenshot from first post) 
    • The issue seems to be related directly to the Custom Connector 
    • Any thoughts on next steps for troubleshooting this? We have an HTTP endpoint On-Prem that we would like to connect to via the Gateway with a Custom Connector.

 

PowerApps Gateway Connection Working.png

seanpanter
Level: Powered On

Re: Not able to connect to the On-Premises Data Gateway

Any other ideas for troubleshooting this issue?

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (6,253)