cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jk264
Helper I
Helper I

Permissions issue

Hi,

I have got an app with 2 screens, one with gallery showing the list of records, second is edit form to create/edit.

The form has about 15 fields of various types, that includes 2 lookups and couple of option sets. So my app is based on 3 CDS entities, one main entity and 2 related entities for lookups. I have created a custom security role, given organisation level permissions to all the 3 entities. I have assigned this role when sharing the app with other user. But for some reason, the lookups and option sets are blank.

If i give System admin role to the user, it works fine.

 

Any thoughts please?

 

Thanks

Jeevan

1 ACCEPTED SOLUTION

Accepted Solutions
v-xida-msft
Community Support
Community Support

Hi @jk264,

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.

 

Please check if you have assigned proper access-level permission of your three CDS Entities to the custom Security Role as below:1.JPG

Please consider create your custom Security Role based on the following article:

https://docs.microsoft.com/en-us/power-platform/admin/database-security#create-or-configure-a-custom...

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-xida-msft
Community Support
Community Support

Hi @jk264,

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.

 

Please check if you have assigned proper access-level permission of your three CDS Entities to the custom Security Role as below:1.JPG

Please consider create your custom Security Role based on the following article:

https://docs.microsoft.com/en-us/power-platform/admin/database-security#create-or-configure-a-custom...

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi,

As i come from Dynamics 365 CE background, i was pretty sure that i have configured the role right, but i missed the bit from the MS documentation that we should have the "Min Privileges to run the App", thanks for the link.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Users online (20,447)