cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Melissaed26
Helper I
Helper I

Powerapps dropdown control stopped working

Hello

 

I have several apps that were created six months ago. In the last couple of weeks the drop down controls that I have added to custom cards on the edit form have stopped populated the values. When an item is selected from gallery it shows in the detail screen. When I select the pencil to edit, on the edit screen these will not load. I have researched to try and find a solution and can not find one. When I have it in the studio environment to make edits to the app it shows correctly. When I publish it and open as a user it does not work. 

 

Please help!

2 ACCEPTED SOLUTIONS

Accepted Solutions

I believe the issue is with selected portion of the formula. When I changed to selectedtext it started working. I saw there was a bug on a youtube video. Thank you for answering!

 

Melissa

View solution in original post

@Melissaed26 We have just completed a hot-fix to restore the previous behaviour when evaluating rules for Form controls and their children after a form is reset or its default mode is changed (new, edit, view).  The issue would most commonly cause list controls (CombooBox, Dropdown, ListBox) to intermittently fail to load data. 

 

Please save your apps(s) and re-published for the changes to take effect. 

 

Studio versions containing the hot-fix are as follows:

  • 3.20053.25 (PROD moderate release ring)
  • 3.20061.28 (PROD US regions)
  • 3.20062.20 (PROD rest of regions)
  • 3.20063.11 (PROD preview regions)

 

We are sorry for any inconvenience this has caused. 

View solution in original post

4 REPLIES 4
v-xida-msft
Community Support
Community Support

Hi @Melissaed26 ,

Based on the issue that you mentioned, I have made a test, and don't have the issue that you mentioned. Recently, multiple users have faced same issue as you, please check the following threads:

https://powerusers.microsoft.com/t5/Building-Power-Apps/Cascading-dropdown-values-visible-in-edit-mo...

https://powerusers.microsoft.com/t5/Building-Power-Apps/Dropdown-list-function-did-not-work-in-publi...

https://powerusers.microsoft.com/t5/Building-Power-Apps/Cascading-dropdown-issue/m-p/590050

 

As an possible solution, please consider take a try with the following workaround:

Set the OnStart property of your App to following:

 

ClearCollect(ChoiceOptions, Choices('Your SP List'.ChoiceField))

 

Then within your Edit form, unlock corresponding Choice field Data card, set the Items property of the ComboBox to following:

 

ChoiceOptions

 

then re-publish your canvas app, then check if the issue is solved.

 

In addition, please also consider edit your canvas app using the following URL Link directly:

https://create.powerapps.com/v3.20061.23.152576243/studio/#

Access above link, and open your canvas app, then made some changes to it (e.g. add a button, then remove it), then re-publish it again, check if the issue is solved.

I have posted this issue to my Product Team, if this issue is solved, I would reply here. Thanks for your feedback.

 

Best regards, 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I believe the issue is with selected portion of the formula. When I changed to selectedtext it started working. I saw there was a bug on a youtube video. Thank you for answering!

 

Melissa

View solution in original post

Hi @Melissaed26 ,

Have you solved your problem?

 

Thanks for your sharing. If you have solved your problem, please consider go ahead to click "Accept as Solution" to identify this thread as "Closed".

 

I have also posted this issue to my product team, and they are investigating this issue, if this issue is fixed, I would reply here. If you do not mind, please share the formula you used to fix this issue for anyone else who faces same issue with you. Thanks for your feedback.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@Melissaed26 We have just completed a hot-fix to restore the previous behaviour when evaluating rules for Form controls and their children after a form is reset or its default mode is changed (new, edit, view).  The issue would most commonly cause list controls (CombooBox, Dropdown, ListBox) to intermittently fail to load data. 

 

Please save your apps(s) and re-published for the changes to take effect. 

 

Studio versions containing the hot-fix are as follows:

  • 3.20053.25 (PROD moderate release ring)
  • 3.20061.28 (PROD US regions)
  • 3.20062.20 (PROD rest of regions)
  • 3.20063.11 (PROD preview regions)

 

We are sorry for any inconvenience this has caused. 

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,806)