cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SarathMohan Helper II
Helper II

Quick questions on PowerApps Admin connector

Hi Team, I am trying to use PowerApps admin connector to fetch the details of environment and apps, I am facing following issues.

1. GetEnvironments not returning defaultenvironment.

2. GetApps - retuens only 250 apps without parameters and with parameter for the top: 1100( max value), in my case I have around 3k apps in default envornment.

 

Let me know if this is a known issue or there are ways to overcome this.

 

TIA,

 

Sarath

 

3 REPLIES 3
Super User
Super User

Re: Quick questions on PowerApps Admin connector

We have over 5k of apps and we are able to get all the apps using COE Starter Kit. The Flow in the COE Starter Kit uses the "Power Apps for Admins (Preview)" Connector and the "Get Apps as Admin" Action. The "Page Size" is set to 1000 and in the settings the pagination is turned on and the threshold is set to 10,000.

 

For the environments issue you could try the "Power Platform for Admins (Preview)" connector and the "Get Environments (Preview)" Action. We haven't had any issues with it returning all the environments.

If you are still having issues make sure the account running the flows has Admin access to the Power Platform.



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.
SarathMohan Helper II
Helper II

Re: Quick questions on PowerApps Admin connector

Thanks for the response rally appreciate it.

1. I am not looking from the flow perspective want to know if all the apps can be retrieved from the connector without invoking the flow.

2. Even if I am the admin at the tenant level unable to retrieve the default environment details, however, there is a workaround that I have found Powerapps makers connector will retrieve the default environment using the same login. This seems to be a little weird for me. The connector behaviour is inconsistent.

 

Regards,

Sarath Mohan

 

 

Super User
Super User

Re: Quick questions on PowerApps Admin connector

You might want to consider installing the Power Platform COE Starter Kit. Once you have that installed and running you can use the app "Power Platform Admin View" and that has a view called Connectors and if open a connector record it shows you all the Apps and Flows that are using that connector. 

 

https://docs.microsoft.com/en-us/power-platform/guidance/coe/starter-kit



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

‘Better Together’ T-Shirt Contest – Winner Announced!

‘Better Together’ T-Shirt Contest – Winner Announced!

And the winner is...

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Power Platform 2020 release wave 1 plan

Power Platform 2020 release wave 1 plan

Features releasing from April 2020 through September 2020

Users online (6,151)