cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
NuttyPistons
Responsive Resident
Responsive Resident

SQL connection not working in dataflow in imported managed solution

In a dev environment, I have an unmanaged solution that contains several Power Platform dataflows that use a connection to SQL server (On-prem gateway). They all work as expected.

 

When I export this solution (as managed) and import into my production environment, the connection reference to SQL needs to be updated in the dataflows. When I edit a dataflow, the first thing I see is a yellow notification saying 'Please specify how to connect.' and a button -- 'Configure connection'. When I select Configure connection, select a working connection, and click 'Connect', the query begins to load for about two seconds before the same yellow notification returns. I know the connection works, as I'm able to create a new dataflow using this connection in the production environment. 

 

I can't figure out why I can't configure the connection -- any help would be much appreciated. I've attached pictures of the screens I'm encountering, including a screenshot of a working dataflow using the same connection reference, but one that was created in the production environment instead of being imported as part of a managed solution.

1 ACCEPTED SOLUTION

Accepted Solutions
NuttyPistons
Responsive Resident
Responsive Resident

For whatever reason, I was able to resolve this by going into Options > Project Options within the dataflow (in the target environment) and then clicking OK. That is where you can change the gateway, but I often don't even need to change it. Just going into the Project Options and clicking OK will do the trick. I sometimes have to click configure connection in the query once more after that, but this resolved the issue for me.

Hope this helps.

View solution in original post

4 REPLIES 4
techsan20
Frequent Visitor

Anyone?  I am having the same issue but my connection is to Oracle using a gateway. 

NuttyPistons
Responsive Resident
Responsive Resident

For whatever reason, I was able to resolve this by going into Options > Project Options within the dataflow (in the target environment) and then clicking OK. That is where you can change the gateway, but I often don't even need to change it. Just going into the Project Options and clicking OK will do the trick. I sometimes have to click configure connection in the query once more after that, but this resolved the issue for me.

Hope this helps.

techsan20
Frequent Visitor

That worked!   Have never used that option screen.  Thanks for your help.

Thank you, Worked for me as well.

 

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Power Apps Ideas

Changes to Ideas Coming

We are excited to announce a new way to share your ideas for Power Apps!

Users online (1,906)