cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Working with environment variables

Hi Guys,

 

I'm trying to make use of environment variables while moving apps between different environments. However after the recent UI changes to the setting menu I'm not able to see the Automatically create environment variables when adding data sources option for automatically creating environment variables when a SharePoint data source is added. Where can I find the same.

 

Regards

Sri

6 REPLIES 6
joe_hannes_col
Impactful Individual
Impactful Individual

Hello @Anonymous,

 

In Power Apps studio, click on "Settings" in the ribbon:

joe_hannes_col_0-1626180813067.png

 

You will find the option to create environment variables at the bottom of the "General" section of the settings menu:

joe_hannes_col_1-1626180843176.png

 

Anonymous
Not applicable

Hi @joe_hannes_col ,

 

Thanks for the reply, but for me the UI for settings has changed and now it looks like the screenshot i have attached with this message.

 

There i cannot find the above feature.

Setting SS.JPG

 

Regards

Sri

joe_hannes_col
Impactful Individual
Impactful Individual

Hello @Anonymous,

 

I just checked and moved to the latest authoring version of Power Apps Studio in my region (3.21063.39), and the setting is still in the same place.

Would you mind sharing your authoring version?

joe_hannes_col_0-1626181474721.png

This is just a workaround, but you could change to a previous authoring version...

Anonymous
Not applicable

Hi @joe_hannes_col ,

 

I'm also in the same authoring version, but only that particular is not showing up. I'll just switch to an old version and see.

Capture1.JPGCapture2.JPG

Regards

Sri

joe_hannes_col
Impactful Individual
Impactful Individual

Good luck, @Anonymous.

 

Just created a canvas app outside of a solution, and I can still see the environment variables setting. It's a long shot, but maybe you could clear the cache or try a different browser.

Anonymous
Not applicable

Hi @joe_hannes_col ,

 

I was able to find that option. It wasn't showing up when I scrolled using my mouse, but when I used 'tab' to move between controls it showed up. I guess its some kind of bug.

 

Anyway really appreciate your efforts.

 

Regards

Sri

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Community Call Conversations

Introducing the Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Users online (1,688)