cancel
Showing results for 
Search instead for 
Did you mean: 

Fix Bug - Environment Variables in PowerApps Solutions do not work with People Picker Fields in SharePoint

There seems to be a defect when People Picker fields in SharePoint are used with Environment Variables in SharePoint. 

 

The solution imports into the environment fine and connects to the new SharePoint Sites and Lists but the People Picker fields will not function.  They become unsearchable and can not connect to any data.  They will display any existing data from the SharePoint list but new data can not be entered and existing data can not be updated.   An error message is displayed saying the list can not be found.

 

I've ran multiple tests and have asked colleagues to do the same and our results are consistent.  The People Picker field does not function when used with Environment Variables.

 

Hoping this can be addressed by Microsoft so we can use this functionality in our environment.

 

Thank you!

Status: New
Comments
SimonGray
Regular Visitor

We ran into this error, removing and re adding the data source connection seemed to remedy the issue

TerraDawn
Frequent Visitor

Thank you! I will try that!    As of now, we are having issues importing solutions. Something has changed in our environment and we lost access to do so but once we regain access I will give that a try!  

andersm
New Member

Re-adding the data source connection defeats the purpose of the Environment Variable in a managed solution.

This is a bug that needs to be fixed by Microsoft before datasource Environment Variable can be used in our ALM.

It is not just the People Picker field but any field that uses the Choice() function.

Aslamzee
New Member

We are not able to use Managed solution in Prod environment due to his bug.