cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate IV
Advocate IV

A Web Form using another Web Form for related record creation on a subgrid

Hello Power Apps Portals Community,

I hope you can help please. 

On a Web Form's Metadata record, in "Grid Configuration" for the "Create" action, instead of using an "Entity Form" can I use another "Web Form" to created a related record that has multiple steps for creation?

The reason I need a second "Web Form" for the related record is that it has subgrids on it, and they can't be added to an "Entity Form", I believe, without code.

Thanks very much,

Garry

4 REPLIES 4
Highlighted
Solution Sage
Solution Sage

Re: A Web Form using another Web Form for related record creation on a subgrid

Hi @GarryPope ,

 

Unfortunately, we have only 3 options for create - Entity Form, Web Page and Url. So in your case, if you would like to have multiple stage guided process, I would suggest creating a web page that will contain a web form and just call it from the grid.

 

Regarding subgrid on the entity form - you can add subgrid to the entity form the same way as you would do for the web form. However, you cannot use subgrid on the creation form for the simple reason - when you create a record from subgrid you usually associate that record in some way to the master record. And on creation form master record does not exist yet.

----------------------------------------------------
If you find this post helpful consider marking it as a solution to help others find it.
Highlighted
Advocate IV
Advocate IV

Re: A Web Form using another Web Form for related record creation on a subgrid

Hello @OOlashyn,

Like always, thanks for the great reply.

Regarding the "Entity Form" comment, I should have worded that better, sorry. I didn't use that option due to it not working on create, which of course, is logical.

 

Thanks for the advice. I've added my second "Web Form" which has two "Web Form Steps" onto a new "Web Page".

 

I then go to my original "Web Form" which was for an Account creation.

On its final "Web Form Step" I have a "Metadata" record with type "Subgrid", which I'm using to display/create a custom entity record.

In the "Grid Configuration" I've enable the "View Action" of "Create", with the below values:

"Target Type" = "Webpage"

"Redirect to Webpage" = My new "Web Page", with my second "Web Form"

Yet, when I follow the process in my portal, click the "Add" button to the subgrid, nothing happens. The page quickly refreshes to exactly the same state it is in, before I clicked the "Add" button.

 

Any thoughts please as to why you think when I click "Add" the "Web Form" is not appearing?

Thanks very much,

Garry

 

Highlighted
Solution Sage
Solution Sage

Re: A Web Form using another Web Form for related record creation on a subgrid

Hi @GarryPope ,

 

Can you access newly created web page directly by URL? If yes I would suggest you try to Sync Configuration first. Open your Portal app for Edit and press Sync Configuration button (some times it doesn't sync it fast enough). After that clear your browser cache and try again. If that doesn't help I would check browser developer console (F12 or fn+F12 on Windows in Chrome) to see if any error occurs when you press Create button. If there is nothing in the console I would open Network tab (it will be in the same Developer tools window that was open for developer console) and check if there is any request that is shown as red when you try to press the button.

 

If nothing of the above will help I would advise you to open a ticket with Microsoft as it clearly should work.

----------------------------------------------------
If you find this post helpful consider marking it as a solution to help others find it.
Highlighted
Advocate IV
Advocate IV

Re: A Web Form using another Web Form for related record creation on a subgrid

Hello @OOlashyn,

Thanks so much for getting back to me. I think it's actually an issue with the webpage my web form is on, your advice is great, but actually I don't think I've provided the right problem to you. I've had to throw in the towel and raise a ticket with Microsoft. 

Thanks, like always, for your excellent help.

Garry

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Users online (8,280)