cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Marie_25
Helper I
Helper I

Business process error - entity does not exist

The following error is showing up when I try to access the Contact entity in the environment: 

 

Marie_25_6-1609767396575.png

There were no changes since the last time it was used and the processes have not been altered. When I try to create a new contact, it is showing me this error: 

 

Marie_25_7-1609767418047.png

Exception 'InvalidPluginExecutionException' occured: Error during retrieval of Configuration Entity: entity doesn't exist in the error log. However, the contact entity does exist within the system.

 

Moreover, on the portal, This error is showing when I try to log in, however, I'm not sure whether they are related: 

Marie_25_8-1609767439820.png

No changes have been made from when the portal was used (and was working fine) till now

Are there any solutions to this please?

1 ACCEPTED SOLUTION

Accepted Solutions
OliverRodrigues
Super User
Super User

Hi Marie 

Can you download the full log details from when you try to open the record via Model-Driven App/D365?

I remember having this issue in the past, I believe the root cause was that I had a custom BPF, created/opened a contact record running that BPF, and then deleted the BPF. Basically D365 was getting lost as couldn't find the BPF that contact was associated to.

Do you think this applies to you?

 

Every time we create a BPF, it creates a table on the background, this table is used to control the transition state of the record against the steps. Can you see if you find this table via Advanced Find, and then delete any entries in case the BPF no longer exists?

 

 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Pages Super User | MVP


Oliver Rodrigues


 

View solution in original post

4 REPLIES 4
OliverRodrigues
Super User
Super User

Hi

have you disabled any existing Business Process Flow associated to the Contact entity?

can you please navigate to Advanced Settings --> Processes --> All Processes

sort by entity and see if there is any BPF associated to the Contact entity and if it is in Draft state. If it is, try to activate it as a test.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Pages Super User | MVP


Oliver Rodrigues


 

Hi Oliver,

Thank you for the suggestion. However, all BPF are activated with relation to the Contact entity. 

OliverRodrigues
Super User
Super User

Hi Marie 

Can you download the full log details from when you try to open the record via Model-Driven App/D365?

I remember having this issue in the past, I believe the root cause was that I had a custom BPF, created/opened a contact record running that BPF, and then deleted the BPF. Basically D365 was getting lost as couldn't find the BPF that contact was associated to.

Do you think this applies to you?

 

Every time we create a BPF, it creates a table on the background, this table is used to control the transition state of the record against the steps. Can you see if you find this table via Advanced Find, and then delete any entries in case the BPF no longer exists?

 

 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Pages Super User | MVP


Oliver Rodrigues


 

Marie_25
Helper I
Helper I

Hi Oliver. Thank you for you suggestion, it helped a lot!

 

I had previously removed the Marketing solution from the environment and there were 2 issues. The BPF "Set Managing Partner on creation of contact via portal" had to be deactivated. The other issue was  the following plugin: Microsoft.Dynamics.Crm.MarketingPlugins.Plugins.Segmentation.SegmentMembersPlugin hence, it was deactivated as well. 

Helpful resources

Announcements
Carousel Community Blog

Check out the Community Blog

Read all about the most recent blogs in the community!

Carousel News & Announcements

What's New in the Community?

Check out the latest News & Events in the community!

Users online (5,864)