cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SBRO
Frequent Visitor

Cannot display FinOps virtual entitiy data via a power portal basic form

Hi,

 

Currently I am working on a power portal. To start of, I have a working List of all the records in a FinOps/D365FO data entity. The data entity is connected to Dataverse via a Virtual Entity. When I go to the page with URL: https://######.powerappsportals.com/###### the List with FinOps data is displaying just fine. 

 

However when I use "Web page for Detail View" to go to a detail page of a list item, I cannot get the web page to display to the FinOps Data via a Basic form. The form shows empty fields. The URL looks something like this: https://######.powerappsportals.com/######/viewdetails/?id=00005887-0000-0000-0000-005001000000. Which makes me think that with all the zeros, somehow having a basic form display virtual entity data is not possible. 

 

What can I do to fix this? When using standard dataverse tables, the drilling down from list to form via "Web page for details View" works automatically. 

7 REPLIES 7
SBRO
Frequent Visitor

2022-03-24_16-08-16.jpg

 

2022-03-24_18-35-08.jpg

ragavanrajan
Super User
Super User

Hi @SBRO 

 

I assume you are using Virtual connectors in Dataverse.  Can you confirm? 

 

 

In fact I used Finance and Operations Virtual Entity. I followed these instructions: https://dynamicspost.com/virtual-entity-enable/

Hi @SBRO 

 

Under the Configure virtual entity - Set the refresh field to yes 

 

ragavanrajan_0-1648337177715.png

Also, I suspect, the connection has to be shared with everyone in the org

 

ragavanrajan_1-1648338163541.png

Can you see if you can find "Shared with Org" 

 

ragavanrajan_2-1648338210050.png

Hope it helps. 
------------

If you like this post, give it a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users to find it.

SBRO
Frequent Visitor

Thank you for your reply. I set the refresh setting but the issue is not fixed yet. Can you indicate where I can find "Shared with  Org" and what I need to do with it? 

 

Moreover I don't think it is a security issue because I can see all the data I want to see in the portal. It more an issue where I want to see the details of a record in a list that is giving me issues. How do I access a record instead of just a list on a portal? 

 

 

Hi @SBRO 

 

I have tested this with a virtual entity SQL connector. The only issue I figured out was sharing with org. Then it was all good.  I can see your data exists in the dataverse section. 

 

Try accessing from Dataverse tables > Data Tab and see if you can access it. 

 

Hope it helps. 
------------

If you like this post, give it a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users to find it.

 

Hi Ragavanrajan. Thanks again for taking the time. Unfortunately I still don't understand where to find "Shared with Org" and what to do with it. This is what I see in the Data Tab: 

SBRO_0-1648740729026.png

For what it is worth, when I make a Model driven app for the same entity. I can browse the list, open a single record, even drill down to related child records and open those child records as well without any additional setup. 

 

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Users online (4,838)