cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SunilR
Helper I
Helper I

Data from CRM not getting updated in Entity List

Hi All,

 

I have a one issue with data update from CRM to Portal.

When a new user register in portal and creates a new record and submit it.

Then when I login to CRM and change some field values. Fields values not getting updated in Entity List view.

If i open record in portal changes are reflecting but in view those vales are same.

 

Thank you.

8 REPLIES 8
hardikv
Solution Sage
Solution Sage

Hi @SunilR

It seems that your Entity List View is taking a value from cache.

Can you please clear the cache for Portal? 

@hardikv  Thanks for your reply

If i clear cache. Data/Changed Values are reflecting. But users does't clear.

so is there any way to handle it.

Hi @SunilR 

Please change tracking option from Entity in Dynamics 365: https://www.youtube.com/watch?v=M1kNYDyZ3fE

 

This issue is mostly for the trial CRM instances. So. If you are facing this issue for your licensed CRM/Portal, Raise a support ticket with Microsoft without wasting the time. Because there is nothing in your control in order to clear the cache except doing the required configuration like Enable Tracking and Publish All Customization at Dynamics CRM end.

Hi @hardikv 

Thanks for your reply

 

Change Tracking is enable for Entity.

Still not showing changed field values in Entity List(CRM View) in Portal. If i open the record data is reflecting with changes i have made.

 

Thanks

 

Hi @SunilR

There is no way to sync data immediately from Dynamics CRM to portal. 

@hardikv 

Thanks for your reply 

 

Actually if i wait for 30 min also data is not reflecting.

Hi @SunilR 

 

SLA for caching is 15 minutes, if your updated data is not reflected in your Portal within that, you should definitely raise a ticket with Microsoft for investigation 

 

At the moment there is no way to force clearing the cache programmatically 

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

Hi All,

 

Issue is with when an user register and create his/her 1st record.

From same user if i create 2nd record data is reflecting within 5 min.

Only for 1st time record issue is there .

 

Thank you.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,883)