cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SunilR
Helper I
Helper I

Edit button not showing on Sub grid records

Hi All,

 

I have two entities Dealers and Payments.

1. Dealers has Payment subgrid on it, Entity Permissions are configured (Dealers, Payment(Child)). Given all privileges. Added Web Roles (3 roles)

2. Dealers configured in Web From Steps. Payments form configured in Entity Form (Edit Mode).

3. I have added subgrid metadata to Dealers Web From Step (In Action Items Edit is configured)

4. For Payment I have added Global Entity Permissions as well. Given all privileges 

 

Still not showing Edit button on Subgurid 

 

Thank you.

2 ACCEPTED SOLUTIONS

Accepted Solutions
OliverRodrigues
Super User
Super User

Hi @SunilR 

 

I think I've faced similar issue before.. can you try a "Details" action in your subgrid instead of Edit? 

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

v-siky-msft
Community Support
Community Support

Hi @SunilR ,

It seems to be a Permission Issue, Could you please try to create a new Entity Form from scratch with Write Permission and try again?

If it still doesn't work, please try to Details Action.

grid2.PNG

Sik

 

 

View solution in original post

2 REPLIES 2
OliverRodrigues
Super User
Super User

Hi @SunilR 

 

I think I've faced similar issue before.. can you try a "Details" action in your subgrid instead of Edit? 

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

v-siky-msft
Community Support
Community Support

Hi @SunilR ,

It seems to be a Permission Issue, Could you please try to create a new Entity Form from scratch with Write Permission and try again?

If it still doesn't work, please try to Details Action.

grid2.PNG

Sik

 

 

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

Users online (2,223)