cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
QuantumRemedy
New Member

Entity Form for Profile Web Form doesn't appear to work

I added a subgrid for a related custom table to the Contact Profile Web Form that is used when you edit your profile. When I add entity form (with entity permissions) and create metadata for the subgrid with a button for "associating", I don't see the button.

 

I also created another contact page with a subgrid for the custom table with entity permissions for a role called Contact Management and that works. Even if I have that role, the button doesn't show up in the profile view. I've double-checked the entity permissions and can't find any issue. Then, I tried adding some JavaScript to the entity form (something simple like alert('test');) and nothing happened, even if I clear my browser cache and clear the cache and config in _services/about.

 

I know that the entity form and metadata is for the right entity form because I can see the subgrid on the Profile view and I can see the subgrid listed when adding the metadata.

 

It seems to me that the Profile Web Form might be protected from entity form alterations? If that is so, is there another way to customize this form?

1 ACCEPTED SOLUTION

Accepted Solutions
ragavanrajan
Super User
Super User

Hi @QuantumRemedy , 

 

Can you try these steps 

1. https://make.powerapps.com/ > Solutions > New Solution > Add Existing > Table > Pick Contact Entity 

2.  And then inside the solution > open contact entity >Form > Profile web Form  

 

ragavanrajan_0-1613511501295.png

3. Now if you edit the profile web form > under related > you can add subgrid and pick the proper custom table 

4. Once done insert it in to the form 

5. Click Save > Publish  

 

And then in solution > press "publish all customizations" 

 

In portal studio: 

1. Refresh the page > and then press "Sync configuration" then "Browse Website" 

 

Hopefully now you can see your subgrid in profile web form. 

 

Hope it helps. 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

View solution in original post

1 REPLY 1
ragavanrajan
Super User
Super User

Hi @QuantumRemedy , 

 

Can you try these steps 

1. https://make.powerapps.com/ > Solutions > New Solution > Add Existing > Table > Pick Contact Entity 

2.  And then inside the solution > open contact entity >Form > Profile web Form  

 

ragavanrajan_0-1613511501295.png

3. Now if you edit the profile web form > under related > you can add subgrid and pick the proper custom table 

4. Once done insert it in to the form 

5. Click Save > Publish  

 

And then in solution > press "publish all customizations" 

 

In portal studio: 

1. Refresh the page > and then press "Sync configuration" then "Browse Website" 

 

Hopefully now you can see your subgrid in profile web form. 

 

Hope it helps. 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

View solution in original post

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Users online (59,993)