cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Entity metadata subgrid item actions automatically reset to "Details" after once reloading it at Powerapps portal management

Hello,

 

I'm currently working on Powerapps portal and an entity form needs to have another entity as subgrids.

I have put subgrids on it when I made the form from model-driven app,

and after I connected it to the target view on powerapps portal, it successfully came to be shown on the form as I expected.

HiroakiSasaki_0-1596806706047.png

The next step is to allow users to CRUD the records. 
I made proper settings (as long as I believe) at entity metadata.

HiroakiSasaki_1-1596807053752.png

At "Item Actions" on Grid Configuration, I put "Details", "Edit" and "Delete" as shown below, and saved it.

HiroakiSasaki_3-1596807359282.png

After refreshing the portal, the settings were successfully reflected on my portal site once, Yay!.....BUT

HiroakiSasaki_4-1596809165214.png


Once I reload the entity metadata setting record on portal management, all item actions got automatically reset to "Details".

And the unintended changes got also reflected on the portal site after the next page refresh...

HiroakiSasaki_6-1596809314298.png

 

I recheck the setting related access policies but still can't solve this problem.
One strange point is that it actually works until reloading/refreshing the entity metadata setting record after setting it.

 

I'm waiting for any small tips or possibilities.

Thank you for reading!

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Super User II
Super User II

Hi

 

that sounds very weird, I would suggest enabling audit for both Entity Form and Entity Form Metadata: https://docs.microsoft.com/en-us/power-platform/admin/audit-data-user-activity#:~:text=To%20start%20...

 

then try to understand how/when the data is being reset to the previous stage.. it looks like a very weird bug, probably worth opening a ticket with Microsoft, I never faced that one myself

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

2 REPLIES 2
Super User II
Super User II

Hi

 

that sounds very weird, I would suggest enabling audit for both Entity Form and Entity Form Metadata: https://docs.microsoft.com/en-us/power-platform/admin/audit-data-user-activity#:~:text=To%20start%20...

 

then try to understand how/when the data is being reset to the previous stage.. it looks like a very weird bug, probably worth opening a ticket with Microsoft, I never faced that one myself

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

Were you able to resolve this I am having exactly the same problem. As soon as you save the subgrid it changes the Edit and Delete item Action to Details. Not sure audit will help. Have also raised a ticket but wondered if you had found a solution?

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Users online (85,248)