cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
db10
Regular Visitor

Error message when trying to edit with entity form pop-up: The record you are looking for couldn't be found.

Hi,

I'm having an issue with editing from a subgrid. When the pop-up opens I receive the message: The record you are looking for couldn't be found.

I have the following list (subgrid within a form). When I click on the name the edit pop-up opens with the error message.

db10_0-1623230378391.png

db10_1-1623230468048.png

 

I don't think its a permission issue because it works when I let the user redirect to a different page with the form instead of using the pop-up. At the moment the edit form uses query string as record source type, but I can't find a way to put the ID in the URL. The other record source types don't seem to work either.

Any help? Thanks.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Ok, so this is for subgrid on the form not on the list. Can you try to change the record id query string to "id" instead of your custom value on both basic form and on metadata?

----------------------------------------------------
If you find this post helpful consider marking it as a solution to help others find it.

View solution in original post

4 REPLIES 4
OOlashyn
Super User
Super User

Hi @db10,

Can you share the screenshot with your edit action configuration? 

----------------------------------------------------
If you find this post helpful consider marking it as a solution to help others find it.
db10
Regular Visitor

Hi @OOlahyn,

This is the edit form I open in the pop-up: 

db10_0-1623307946293.png

 

This is the subgrid entity form metadata from where I would like to reach the form: 

db10_1-1623308081723.png

 

When I select Webpage for Target Type it opens a new page and it works fine. When I select Entity Form it opens the pop-up with the error message as seen in a screenshot in my original post. 

Thanks for helping.

 

Ok, so this is for subgrid on the form not on the list. Can you try to change the record id query string to "id" instead of your custom value on both basic form and on metadata?

----------------------------------------------------
If you find this post helpful consider marking it as a solution to help others find it.

View solution in original post

db10
Regular Visitor

@OOlashynThank you very much. That fixed it indeed.

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (1,101)