cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
seljm
Frequent Visitor

How to View and Edit Web Form Submission From Entity List View

Hi all,

 

I need to be able to view and edit a web form submission from an entity list view. When I submit a completed web form, I see the data from the submission in my list view and the option to view details; however, I don't see the option to edit and when I click "view details" it redirects to a blank web form. I'm new to Portals and am not sure what I might be doing wrong. I've included images below of my web form steps and entity list.

 

I created an entity (Profile_Test) and a Form (Form_Test) with three tabs. I inserted the Form_Test

Web Form 0.1.JPG

The second and third tabs are pulled from the same form with the record source listed as the results from the previous step.

Web Form 0.3.JPGI created a view titled Test Profile Submission from the same entity name

List 0.1.JPG

I selected target type as webpage and listed the redirected webpage to the page the web form is inserted (Test Page 3) and the Record ID Query String parameter name (ID).

List 0.2.JPGList 0.3.JPG

 

The data appears in the list view but there is no option to edit and view details directs the page to a new web form.

List 1.0.JPG

 Any help would be appreciated. Thanks!

 

 

 

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
OliverRodrigues
Super User
Super User

Hi

 

for you to continue a Web Form, you need to pass the webformsessionid in paremeter as well, not only the record ID

I can't seem to find any online post on that, an advice would be storing the current session in a lookup on your main record (via plugin/workflow), and then add JS to inject the webformsessionid in the URL


------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

v-xida-msft
Community Support
Community Support

Hi @seljm ,

Have you enabled Entity Permission option for your "Test Profile Submissions" Entity List?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. I think there is something wrong with your operation.

 

Firstly, if you want the "Edit" option to be shown up in your Entity List, please make sure you have configured the "Edit" Item action under "Grid Configuration" part of your Entity List as below:

9.JPG

And please also make sure you have enabled "Enable Entity Permission" option for your Entity List as below:

10.JPG

 

Then go to your Portal Designer, then click "Sync Configuration"-> "Browse website" to make the changes you made in your Portal Management take effect:

 

11.JPG

 

After that, the "Edit" option would be shown up under your Entity List as below:

12.JPG

 

Note: In order to show "Edit" option and "Delete" option in your Entity List, you must configured corresponding Item action under the  "Grid Configuration" part mentioned above, and enable "Enable Entity Permission" option for your Entity List.

 

 

 

Please consider take a try with above solution, check if the issue is solved.

 

Best regards,

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

10 REPLIES 10
hardikv
Solution Sage
Solution Sage

Hi @seljm

Did you clear the cache? 

For edit, you can also click on 'state'. 

OliverRodrigues
Super User
Super User

Hi

 

for you to continue a Web Form, you need to pass the webformsessionid in paremeter as well, not only the record ID

I can't seem to find any online post on that, an advice would be storing the current session in a lookup on your main record (via plugin/workflow), and then add JS to inject the webformsessionid in the URL


------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

v-xida-msft
Community Support
Community Support

Hi @seljm ,

Have you enabled Entity Permission option for your "Test Profile Submissions" Entity List?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. I think there is something wrong with your operation.

 

Firstly, if you want the "Edit" option to be shown up in your Entity List, please make sure you have configured the "Edit" Item action under "Grid Configuration" part of your Entity List as below:

9.JPG

And please also make sure you have enabled "Enable Entity Permission" option for your Entity List as below:

10.JPG

 

Then go to your Portal Designer, then click "Sync Configuration"-> "Browse website" to make the changes you made in your Portal Management take effect:

 

11.JPG

 

After that, the "Edit" option would be shown up under your Entity List as below:

12.JPG

 

Note: In order to show "Edit" option and "Delete" option in your Entity List, you must configured corresponding Item action under the  "Grid Configuration" part mentioned above, and enable "Enable Entity Permission" option for your Entity List.

 

 

 

Please consider take a try with above solution, check if the issue is solved.

 

Best regards,

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

seljm
Frequent Visitor

Hi @hardikv 

 

Thanks for your response.

 

I tried clearing the cache and I clicked 'state' as well for both records. Unfortunately, no luck.

Hi @OliverRodrigues 

Thanks! That worked. After passing the webformsessionid I also had to disable multiple records per user but seems to be working now.

Thanks again.

 

Hi @v-xida-msft 

 

Enabling the entity permission worked and I can see both view details and edit. Thanks for the help!

Also, the previous response from @OliverRodrigues with passing the webformsessionid enabled the 'edit' option and populated the web form with the previously entered data.

 

I appreciate the help.

Hi @OliverRodrigues , I have a similar situation, my webform shows 3 forms from different entities and when I open the same from the entity list, after the first step, it shows a blank page. Maybe as you suggested, I might need to store and pass the webformsessionid. I am new to Portals, do you have any samples that can help me to implement this approach?

Sahil
Frequent Visitor

Hi @seljm could you please suggest how to pass the webformsessionid to the edit page?

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,305)