cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
byansakura
Advocate II
Advocate II

Migrating Portal to Environment

Hey, I was trying to move my portal to a new environment since the trial has exceeded its given time. I succeeded in moving the forms and entities, however the portal show a blank Custom Portal instead of my customized starter portal. The starter portal existed in portal management, but I have no idea on how to change the Portal App so it shows my newly added starter portal instead of the default custom portal. Is there anyway I can change the website to my imported portal which is starter portal? Thank you!

byansakura_0-1601294254637.png

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
OliverRodrigues
Super User II
Super User II

Hi

 

Just wondering what's the method you are using to transfer the records? 

also how did you provision the Portals? if you provisioned differently that might have caused you to have different Portals types - thus different Website GUIDs

if you can re-provision the Portals would be better, otherwise you will have to re-associate every Portal record (web pages/entity forms/etc) to the new Website record

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

Hi @byansakura,

If they're two different portal types then you shouldn't have an issue - just go to your Website Binding and change the Website lookup to your Starter Portal, then make sure your Starter Portal's URL is pointing to the URL of your new environment.

Website Binding:

justinburch_1-1601316873770.png

Website:

 

justinburch_0-1601317048543.png

 

Note that you may need to reset your Portal (not the cache, the entire Portal) for the changes to reflect.

https://docs.microsoft.com/en-us/powerapps/maker/portals/admin/reset-portal

 

View solution in original post

7 REPLIES 7
OliverRodrigues
Super User II
Super User II

Hi

 

Just wondering what's the method you are using to transfer the records? 

also how did you provision the Portals? if you provisioned differently that might have caused you to have different Portals types - thus different Website GUIDs

if you can re-provision the Portals would be better, otherwise you will have to re-associate every Portal record (web pages/entity forms/etc) to the new Website record

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

Thank you @OliverRodrigues I first reset the portal in the previous environment then provision a new portal, then i imported the old portal to that environment. maybe i provisioned a custom portal. should i delete that and do a re-provision and reimport? i dont really grasp the idea of portal re-provision though.

Hi @byansakura,

If they're two different portal types then you shouldn't have an issue - just go to your Website Binding and change the Website lookup to your Starter Portal, then make sure your Starter Portal's URL is pointing to the URL of your new environment.

Website Binding:

justinburch_1-1601316873770.png

Website:

 

justinburch_0-1601317048543.png

 

Note that you may need to reset your Portal (not the cache, the entire Portal) for the changes to reflect.

https://docs.microsoft.com/en-us/powerapps/maker/portals/admin/reset-portal

 

View solution in original post

Thank you, @justinburch  . I've changed the lookup to my starter portal in the website binding and made sure that the website is right I also have reset the portal. Then the portal is missing and so is the website binding. Is there anything I missed?

byansakura_0-1601319676550.png

 

dear @justinburch and @OliverRodrigues , thank you for the insight! i finally adjust the form one by one and it works. it would be great if i dont have to do that and just do a website binding later when i move this portal again. however it fixes my problems for now. 

Thanks for the heads up, @byansakura. Hopefully if you ensure it's the same portal type on creation you won't face the problem again, as it should keep the same GUIDs for all of the records.

great it's sorted

just remember now in case you provision a new Portal to create the same type as you did now - the custom Portal (you might need this when you go to PROD)




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (1,829)