cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dcfm63
New Member

Modal Lookup does not show search box

Dear community,

 

I have a lookup in an Entity form, when I open the modal lookup to pick an Account, the Account lookup view is displayed but I can't see the seach box to write in and look for the account I need. 

 

I open the lookup from an entity form that is called from an grid action in my main webpage. So, the process is the following:

 

I have my web page that have a subgrid and button for create (marked in red) from which I open an Insert Entity Form.

 

dcfm63_2-1637082409089.png

The entity form has a lookup to Account table.

 

dcfm63_3-1637082497829.png

 

From here, I open the lookup modal.

 

dcfm63_1-1637082160579.png

 

By default, I should have the search box on the right corner (marked in red).

 

I need to be able to search among existing accounts, there are to many records and for the users is difficult to navigate and look for the account they need.

 

Any idea on how to sort this out? 

 

Thank you

5 REPLIES 5
chleverenz
Super User
Super User

Hi @dcfm63 ,

no solution but could it be that

  • the searchbox is there but due to your customized css it is not visible?
  • or the portalsoftware is so smart it finds out, that there are no searchable columns in the view and omits the searchbox (never checked on thet one, would be great)

Just thoughts. Have fun,

  Christian

Manar
Super User
Super User

Hello @dcfm63 , 

My guess this is an entity list , can check if the "search" feature enabled for this specific entity form?

 

Manar_0-1637337465023.png

 

Thank you,
Manar

If you like this post, give it aThumbs Up. Where it solved your query, mark it as a SOLUTION so it can help other people!

Hi @chleverenz 

 

  • I think the searchbox is not there because I can´t see it if I try to inspect the element.
  • Its an Account Lookup View, I should be able to search by name the accounts in the system.

Thanks in advance for your feedback.

Hello @Manar 

 

It's not an entity list, It's the default Account Lookup View displayed when you configure a lookup field. I want to highlight that the search box appears for the same View if the lookup field is in the route webpage, I have my lookup field in an entity form that opens from a creation action in the route webpage.

 

Thanks for your feedback.

 

Regards

chleverenz
Super User
Super User

Hi @dcfm32 ( nor @dcfm63 ? 🙂 ),

just another thought: do you have any kind of tablepermission "append to/from account" to your entity? There are tablepermissions wich say append/append to. If they are not checked you would not be allowed to set up lookupdata. May be, you only have read rights, but no append/append to rights.

Could you please check?

(see tablepermissions for your portal on account whether there is at least one tablepermission which has append/append to enabled which is assigned via a webrole to the user (or anonymous) who you are using)

Hope the clears the fog a little bit,

  Christian

 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Super User 2 - 2022 Congratulations 768x460.png

Welcome Super Users

The Super User program for 2022 - Season 2 has kicked off!

Top Solution Authors
Users online (4,205)