cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
matthu
Helper II
Helper II

Navigations missing in studio

Hi, 

 

I recently exported my Portal from test to live using XRM toolbox and I have had a few issues, mainly I am fixing them in my live environment like lists not being displayed on pages even though they were successfully imported. 

 

One major issue I am having is that on my blank page template in the studio I want to change my header navigation - in Test i have five options for the set to choose from:

 

- Default

- Footer

- Primary Navigation

- Profile Navigation

- Secondary Navigation

 

But in live my only options are:

 

- Default

- Secondary Navigation

 

The other three are all in my active weblink sets but not available in Portal studio? Can anyone help?

 

Also I tried to add a link in the new navbar (as I have successfully done in DEV) to my website and i do this via the front end, it appears then I go to the portal studio, refresh and it appears there too then when I "Browse website" the new link just disappears never to be seen.

 

Any help would be most appreciated,

 

Thanks 

 

Matthu 

2 ACCEPTED SOLUTIONS

Accepted Solutions

@matthu 

 

The last thing you can check is, open the weblink set and check whether it has mapped to right website or not? If your live environment has more than one website. In that case only those options are not appearing while editing.

 

Even I tried with publishing state as draft, those option appeared in editor.

 

Other than that I do not foresee any issue. I have tried from my side it worked perfectly.

 

Let me know if that works.

 

 

Regards,

Prakash

View solution in original post

Hi @matthu 

 

    Every web link set contains Web pages. If it is moved successfully then your web pages should also appear. Did you check the Portal record mover logs? 

 

As @Prakash4691  mentioned there is an associated website for every web link set. 

 

If you still have a problem please use record mover again and try one more time but only pick the following tables 

 

ragavanrajan_0-1631230253951.png

Hope it helps. 
------------

If you like this post, give it a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users to find it.

 

View solution in original post

10 REPLIES 10
matthu
Helper II
Helper II

As an example, I have uploaded the image of the studios of dev and live so you can clearly see what is missing. 

Prakash4691
Solution Supplier
Solution Supplier

@matthu ,

 

Some times we face that issue.

 

Try clearing browser cache for options disappearing from website while edit.

 

Options to available in website after importing, try sync configuration and browse the website.

 

If it answers your question, kindly give kudo and accept it as solution.

 

 

Regards,

Prakash

Hi Prakash,

 

Thank you for your response but those were all things I had done as standard. I did try them again anyway but unfortunately, that hasn't helped.

 

Thanks,

 

Matt

ragavanrajan
Super User
Super User

Hi @matthu 

 

Please confirm which tool you have used from Xrm toolbox? 

 

Because you have stated that the import was successful. 

 

Could you please try my below blog details 

 

 https://link.medium.com/rcRn9Vqikjb 

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

 

 

@matthu ,

 

I hope you have used portal record mover plugin from xrm toolbox for import.

 

Did it successfully imported without any issue? You can also check for log for any issues. 

 

Make sure while exporting from dev w.r.t weblink sets, include respective weblinks->webpage->pagetemplate->webtemplate. if any record if you fail to include import might fail.

 

For ex: if you import webpage with entity list, import of webpage will fail if entity list doesn't include while importing.

 

Regards,

Prakash

matthu
Helper II
Helper II

Hi both,

 

I did indeed use portal record mover plug in. 

 

The funny thing is all five weblink sets do appear in my portal site settings.

 

So that must mean the portal record mover successfully brought them across from test to live...

 

But they do not appear in the portal studio?

 

Thank you for your efforts,

 

Matthu

@matthu 

 

The last thing you can check is, open the weblink set and check whether it has mapped to right website or not? If your live environment has more than one website. In that case only those options are not appearing while editing.

 

Even I tried with publishing state as draft, those option appeared in editor.

 

Other than that I do not foresee any issue. I have tried from my side it worked perfectly.

 

Let me know if that works.

 

 

Regards,

Prakash

View solution in original post

Hi @matthu 

 

    Every web link set contains Web pages. If it is moved successfully then your web pages should also appear. Did you check the Portal record mover logs? 

 

As @Prakash4691  mentioned there is an associated website for every web link set. 

 

If you still have a problem please use record mover again and try one more time but only pick the following tables 

 

ragavanrajan_0-1631230253951.png

Hope it helps. 
------------

If you like this post, give it a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users to find it.

 

View solution in original post

matthu
Helper II
Helper II

Thank you both for your input and efforts. I checked through all of your suggestions (and I advise anyone with this issue to do the same as it will no doubt solve the issue) following direct support from Microsoft in which we covered the same steps pretty much we agreed that i would recreate the web link sets and then copy back a copy of my portal from live to dev so they were identical and I could continue developing in dev. Although this doesn't explain why the issue occurred - I'm afraid we will never know but at least i am up and running again and hopefully the thread above will help others 🙂

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,128)