cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Power Apps Portal don't show forms - The record you are looking for couldn't be found

Hi,

 

After I'm working on upload file in SharePoint via form, Power Apps portal stops to show me every form in my site, also the default entity form. While other type of item like Image or List are visible. The error reported is "The record you are looking for couldn't be found".

 

Have you some suggestions to solve this problem?

 

Thanks,

Mauro

 

 

10 REPLIES 10
Highlighted
Solution Sage
Solution Sage

Re: Power Apps Portal don't show forms - The record you are looking for couldn't be found

Did you create any entity permissions as part of the Sharepoint Integration setup?

if so I would suggest reviewing them.. or removing for test


------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Highlighted
Frequent Visitor

Re: Power Apps Portal don't show forms - The record you are looking for couldn't be found

Thanks @OliverRodrigues, 

But I still can't see form, I mean I can't see also form that's stored in CDS, not only the form that using SharePoint integration. In fact if I create a new Entity, assign a form by following the normal procedure to insert the form, that form still don't appear. It seems like there is a bug in software or a bug caused by my some previous wrong configuration.

After looking at @BrianKnight  's post: https://powerusers.microsoft.com/t5/Power-Apps-Portals/Entity-forms-not-showing/m-p/550941#M1434 I notice that by changing the page template from Page with Title to Full Page the error disappear but the form is still not visible.

Thanks,

Mauro

Highlighted
Solution Sage
Solution Sage

Re: Power Apps Portal don't show forms - The record you are looking for couldn't be found

it's probably not a bug, but mis-configuration yes

the web page record must be pointing to the "Full Page" Page Template, and make sure the 2 web page records are pointing to that

every web page has a parent and child web page, both should be pointing to the same Page Template

 

also make sure your "Full Page" Page Template is pointing to the "Full Page" Web Template, this web template must contain the following in the source: 

  {% if page.adx_entityform %}
    {% entityform id: page.adx_entityform.id %}
  {% endif %}

finally, remember to clear the cache for any configuration change: https://docs.microsoft.com/en-us/powerapps/maker/portals/admin/clear-server-side-cache


------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Highlighted

Re: Power Apps Portal don't show forms - The record you are looking for couldn't be found

Hi @Mauro88 I experienced the same problem. As @OliverRodrigues is mentioning above me, you'll need to make sure the page supports forms by either inserting the reference code in there or choosing a template that supports the form. Try giving the Default Studio Template a whirl. That one has the necessary code to show your form. You can later add it to any template using the Liquid language. 

Highlighted
Frequent Visitor

Re: Power Apps Portal don't show forms - The record you are looking for couldn't be found

Hi @Mauro88 and @OliverRodrigues

Newbie here: I experience a slightly similar problem. On a page I show a list of records. When trying to view the details while browsing, of that record I get the message "The record you are looking for can not be found".

 

Adding a new record is possible form that page.

 

In design mode I can select the form that I have included in the portal management app. 

 

What could be the problem?

 

Wim

Highlighted
Solution Sage
Solution Sage

Re: Power Apps Portal don't show forms - The record you are looking for couldn't be found

if it is the same issue the suggested solution is here in the previous answers

have you checked if that is your case?

Highlighted
Frequent Visitor

Re: Power Apps Portal don't show forms - The record you are looking for couldn't be found

I have checked. yes. However, answer is a bit cryptic for me 🙂 "Give studio a whirl" ???? I don't know what that means 🙂

 

Also I am not a programmer, but learning Portals without the necessity of code (I thought that was the whole intention of Microsoft).

 

So I try to debug with only the low-code options the platform gives me. 

 

1. Create entities in CDS 

2. Create relationships, forms, views etc in CDS 

3. Use Portal management to introduce these  components in my Portal

4. Build the portal with these components

5. If it works, refine

 

Put on top of this the fact that I have never worked with Dynamics and then you can imagine my challenge 🙂 

 

Wim

Highlighted
Solution Sage
Solution Sage

Re: Power Apps Portal don't show forms - The record you are looking for couldn't be found

Hi @wimhofland ... I know Microsoft is encouraging people to use more the Portal Studio, but I personally don't recommend at the moment, I know they keep improving it but there are still too many flaws 

 

anyway, try the following via D365

  • open make.powerapps.com
  • go to Apps on the left menu 
  • click Portal Management
  • on the left menu navigate to the Web Pages
  • when you created your Web Page via Portal Studio, you gave it a name, locate your web page and open the record
  • the "Page Template" field might be set to "Default studio template", change that to "Full Page"
  • Save the record, but still on the same page, you can find a subgrid for "Localized Content", which contains another Web Page record, open this Web Page and make sure the Page Template is also set to "Full Page"
  • now open your Portal, login as Admin and clear the cache: https://docs.microsoft.com/en-us/powerapps/maker/portals/admin/clear-server-side-cache
  • open your web page with your list again and see if you are getting the same issue


    ------------

    If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

     

     

Highlighted
Frequent Visitor

Re: Power Apps Portal don't show forms - The record you are looking for couldn't be found

All,

 

excuse me for my ignorance, I found it.

typical a newbie issue. 

 

On the focus Page where my view on the entity was shown I wanted to view details so I selected form (I thought I could see details on same page :-))

In stead I had to create a new page with a form section. That did it for me.

 

I hope I haven't ruined my chances for asking questions to you guys when I am a little bit further in my attempt to master Powerplatform Portals.

 

Thanks for your patience 

 

Wim

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Users online (10,437)