cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
davidyc
Frequent Visitor

Power Portal Create Entity Form: Not generating tabs as steps

As per title, I have an entity form (used for the create action on a subgrid) in the Power Portal that will not create tabs as steps when it loads. Loads first tab of form only and displays no buttons (e.g. 'Submit' or 'Next').

 

Any guidance much appreciated. 

1 ACCEPTED SOLUTION

Accepted Solutions
OliverRodrigues
Super User II
Super User II

I did a quick test here and the next/previous steps worked fine. Subgrids didn't work though, but again I was just doing a quick test.

I normally don't really use that option from Entity Forms, you are better off with Web Forms in my opinion. They are a bit trickier to setup but you will have more options there.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

7 REPLIES 7
davidyc
Frequent Visitor

When the exact same form is used as an 'edit' action on the subgrid the form loads tabs as steps perfectly. Is it a limitation of the 'create' action for a subgrid?

lthomas927
Regular Visitor

Are you trying to use a multi-step form for creation? If so, then you want to use a webform instead of an entity form.

OliverRodrigues
Super User II
Super User II

I did a quick test here and the next/previous steps worked fine. Subgrids didn't work though, but again I was just doing a quick test.

I normally don't really use that option from Entity Forms, you are better off with Web Forms in my opinion. They are a bit trickier to setup but you will have more options there.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

davidyc
Frequent Visitor

Thanks all for replies - I think I missed a vital detail - the entity form I want to use for a 'Create' action on a subgrid is all within the context of a webform step. In other words, I am using a webform with around 15 steps and on one of the steps there is a subgrid which requires entity forms for each action on the subgrid. I would like to set up an entity form on the create action that will use the 'generate tabs as steps feature'.

 

Does anyone know if this works by default?

Hi @OliverRodrigues do you have any other thoughts based on the extra info given in my post below? Thanks in advance.   

Fubar
Solution Specialist
Solution Specialist

If I understand what you are asking correctly, I don't think it will work.  I think you are asking inside a Webform, on one of the Webform Steps you have a subgrid and for that subgrid you want to have a Create new item that then fires another Webform (with multiple steps).  Off the subgrid you would need to use a Web Page (to contain the Web Form) and from memory I think this then breaks the first Web Form.  (I may be wrong, but I think what you want wont work).

@Fubar is right in that you will need another web page to contain the second web form. But I don't think it will break the first web form if you have the setting for "start new session on load" unchecked. This way, you can have the second web form redirect back to the first web form's page on submit and it will start you back where you left off.

Helpful resources

Announcements
User Groups Public Preview

Join us for our User Group Public Preview!

Power Apps User Groups are coming! Make sure you’re among the first to know when user groups go live for public preview.

Power Apps Community Call

Monthly Power Apps Community Call

Did you miss the call?? Check out the Power Apps Community Call here!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (56,103)