cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
velardecrj
Frequent Visitor

Problems with decimal values format in Entity form

Hello, 

 

I use a Entity Form, wich has a numeric field. When the value is a decimal number,  I have problems with the format, because if I enter 1.2 , in dynamics 365, the field shows 12. 

 

How can I solved this?

12 REPLIES 12
OliverRodrigues
Super User
Super User

Hi, can you try with "," instead of "." as decimal separator?

 

this could be an issue with the dataverse datatype formatting 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

ArchitectMadhan
Responsive Resident
Responsive Resident

Hi @velardecrj ,

 

Please let me know, what type of field you are trying to store the decimal number in Dynamics 365? Floating point number or Decimal number or whole number?

Hello:

 

I am triying to store Foating point number. But when a user enter a number in the form ( for example: 1.25), Dynamics is showing 125. 

 

Please note that users that fill the form are 'unauthenticated' user, so in dynamics 365 the 'Created by' value is 'System user' .

Hi @velardecrj ,

Are you using Entity form in Dynamics 365 Portal? I understand that you are trying to store floating point number, but what is the Entity Field Data type?

 

Hello. The field data type is decimal number (with 2 decimals).

 

The problem is the format.  In my entity form I have to enter 1,50 instead 1.50, in order to get the correct number. But users always use decimals with point number, so in Dynamics the field shows 150. 

OliverRodrigues
Super User
Super User

Thanks, so it's working using "," as separator, this looks like a data formatting issue.

Can you try navigating to Power Platform admin center (microsoft.com) --> select your environment --> Settings --> Business --> Regional Formatting:

OliverRodrigues_0-1625684167426.png

the idea here is actually to get to the system settings --> any option above will get you there

on the top menu, select settings --> administration:

OliverRodrigues_1-1625684300218.png

 

now click on System settings --> Formats: 

OliverRodrigues_2-1625684331828.png

select your local format, and then refresh the Portal cache 

 

 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

Hello Oliver, we have configured setttings that youy describe for our users (employees), but take into consideration that the form is filled for unauthenticated user, so, finally, the user/propietary is 'System user', wich not have this format configuration. 

 

 

OliverRodrigues
Super User
Super User

Hi, you probably did that in the user personal settings.

The steps above should apply to the system level.. have you tried that? 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

Hello:  I have configured at the system level, but the problem persist.  What other options could I try?

 

velardecrj_0-1625822857999.png

 

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Users online (2,147)