cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Tim5
Frequent Visitor

SharePoint integration problem

 

Despite going through the guidance at https://docs.microsoft.com/en-us/powerapps/maker/portals/manage-sharepoint-documents several times whenever I get to the form containing the subgrid for documents I get the error.

 

"You don’t have permissions to view these files and folders."

 

I have created

  • entity permissions (all privileges ticked) and
  • document location permissions and applied this to the Anonymous web role. 
  • Enable entity permissions is ticked on the relevant web form step for the entity.


I feel I must have missed something obvious, any ideas anyone please?

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
OliverRodrigues
Super User II
Super User II

Hi, did you make sure to associate your entity permission with a web role? 

did you clear the cache?

 

take a look at this video to make sure you followed all the steps: https://www.youtube.com/watch?v=Scr-8ELjRlI&t=2s

 

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

2 REPLIES 2
OliverRodrigues
Super User II
Super User II

Hi, did you make sure to associate your entity permission with a web role? 

did you clear the cache?

 

take a look at this video to make sure you followed all the steps: https://www.youtube.com/watch?v=Scr-8ELjRlI&t=2s

 

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

Thanks Oliver, it started working this morning so I reckon clearing the cache would have done trick. Glad it was something simple. Thanks for the help.

 

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,895)