cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

SharePoint integration problem

 

Despite going through the guidance at https://docs.microsoft.com/en-us/powerapps/maker/portals/manage-sharepoint-documents several times whenever I get to the form containing the subgrid for documents I get the error.

 

"You don’t have permissions to view these files and folders."

 

I have created

  • entity permissions (all privileges ticked) and
  • document location permissions and applied this to the Anonymous web role. 
  • Enable entity permissions is ticked on the relevant web form step for the entity.


I feel I must have missed something obvious, any ideas anyone please?

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Super User II
Super User II

Hi, did you make sure to associate your entity permission with a web role? 

did you clear the cache?

 

take a look at this video to make sure you followed all the steps: https://www.youtube.com/watch?v=Scr-8ELjRlI&t=2s

 

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

2 REPLIES 2
Super User II
Super User II

Hi, did you make sure to associate your entity permission with a web role? 

did you clear the cache?

 

take a look at this video to make sure you followed all the steps: https://www.youtube.com/watch?v=Scr-8ELjRlI&t=2s

 

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

Thanks Oliver, it started working this morning so I reckon clearing the cache would have done trick. Glad it was something simple. Thanks for the help.

 

Helpful resources

Announcements
News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

Power Apps Community Call

Power Apps Community Call- January

Check out the Power Apps Community Call for January 2021

PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

Users online (3,784)