cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
steveowilson
Microsoft
Microsoft

Traffic Analytics Changes wont deploy

I successfully hooked up my PowerApps Portal to my analytics provider (Google) by putting in my GTAG JavaScript snippet into the traffic analysis settings via the Portal Management portal.  This worked no issues and I see my analytics data flowing from all pages.  However I am now trying to update this snippet and finding changes are not propagated after saving.  I have tried restarting the portal but no changes are deployed.  Even if I remove the snippet completely the old settings remain.

 

How do I force the analytics JS snipped to get applied to my site - this is blocking as I need to move to an alternative provider.

 

Thanks

6 REPLIES 6
v-siky-msft
Community Support
Community Support

@steveowilson 

 

To make changes work, you have to go to edit the portal and click the 'Browse website' after saving the change on snippet, then the change will deploy.

Sik

 

No effect - the old gtag JavaScript still remains.

dileeps
Power Apps
Power Apps

Check the content snippet called "Tracking Code", see whats the value of script in that snippet. This snippet is created/updated by traffic analysis UI.

MrMeeseeks
Frequent Visitor

I am experiencing the same issue right now, did anyone find a solution to this?

Hi @MrMeeseeks , 

 

      I have tested this and it seems like gtag is removed when you delete the content snippet ( not deactivate) 

Here are the steps for you 

 

1. In Portal Management > Content Snippet > Believe you are having your "Tracking Code" Content snippet . 

2. Add your gtag script under value 

3. Go to your portal studio > refresh > and press "Sync configuration" 

4. In a new tab > load the website and then hit "Ctrl+ F5" 

 

If you look at the Chrome Dev tools >  network tab > you can see "Analytics.js" is now loading (Screenshot for your kind reference) 

 

ragavanrajan_0-1614713375412.png

 

Delete the Tracking Code snippet: 

 

1. In portal management > content snippet > Select Tracking Code and delete it 

2. In Portal studio > > refresh > and press "Sync configuration" 

4. In a new tab > load the website and then hit "Ctrl+ F5" 

 

In Chrome dev tools > network tab 

 

 

Screenshot 2021-03-03 083258.png

 
 

 

Hope it helps. 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

 

MrMeeseeks
Frequent Visitor

Thanks @ragavanrajan ! I noticed that I had multiple "Tracking Code" snippets saved in Content Snippets. This is clearly a bug.
For anyone having this issue, please see screenshot below - just remove "Tracking Code" that is no longer relevant and do Sync Config as described in above responses
trackkk.PNG

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

MPP IDEAS updated 768x460.png

Ideas

Discover ideas and concepts from users like you for how to use Power Pages and take your work to the next level.

Top Solution Authors
Users online (4,670)